Installing Mercurial 2.1 doesn't work #10611

Closed
tamm0r opened this Issue Mar 1, 2012 · 3 comments

Projects

None yet

3 participants

@tamm0r
tamm0r commented Mar 1, 2012

Installing Mercurial 2.1 created the following error:

Warning: inreplace in '/usr/local/Cellar/mercurial/2.1/bin/hg' failed
Expected replacement of '(?-mix:#!/./python/.)' with '#!/usr/bin/env python'

Environment: OSX 10.7.3, XCode 4.3

Gist: https://gist.github.com/1b5c9e26a5cf6aaff200

Doctor:
==> /usr/bin occurs before /usr/local/bin
This means that system-provided programs will be used instead of those
provided by Homebrew. The following tools exist at both paths:

git
git-cvsserver
git-receive-pack
git-shell
git-upload-archive
git-upload-pack
gitk
sqlite3
svn
svnadmin
svndumpfilter
svnlook
svnserve
svnsync
svnversion

Consider editing your .bashrc to put /usr/local/bin
ahead of /usr/bin in your PATH.

Some brews install binaries to sbin instead of bin, but Homebrew's
sbin was not found in your path.

Consider editing your .bashrc to add:
/usr/local/sbin
to the PATH variable.

@mxcl
Member
mxcl commented Mar 1, 2012

It did work, that's just a warning.

@2bits
Contributor
2bits commented Mar 1, 2012

See also: 8c0ff06 You may need to brew update to get it.

@tamm0r
tamm0r commented Mar 1, 2012

Works like a charm!

@mxcl mxcl closed this Mar 1, 2012
@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.