This repository has been archived by the owner. It is now read-only.

Ruby should have gdbm as a dependency #11735

Closed
frangio opened this Issue Apr 18, 2012 · 2 comments

Comments

Projects
None yet
2 participants

frangio commented Apr 18, 2012

The dbm library which is part of Ruby stdlib is not installed if it doesn't find a dbm implementation (such as gdbm) on the computer.

I was unable to require 'yaml/dbm' on my Homebrew Ruby installation, so I uninstalled it, installed gdbm, and reinstalled Ruby, and the problem was fixed.

See this related issue by the developer of the Psych YAML engine (although on a different project).

Contributor

adamv commented Apr 18, 2012

We do this for Python, seems reasonable.

@ghost ghost assigned adamv Apr 18, 2012

Contributor

adamv commented Apr 19, 2012

Fixed in bf3dfa9 - thanks for the suggestion.

@adamv adamv closed this Apr 19, 2012

@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.