This repository has been archived by the owner. It is now read-only.

ffmpeg --with-rtmpdump: ./configure can't find pkg-config && librtmp #15260

Closed
stuarts opened this Issue Oct 3, 2012 · 6 comments

Comments

Projects
None yet
4 participants

stuarts commented Oct 3, 2012

Commands && output:
https://gist.github.com/3824299

If I install --interactive and ./configure with the same flags it has no problem.

pkg-config --version returns 0.27.1 and it seems like pkg-config sees librtmp

➜  ~  pkg-config --list-all | grep rtmp
librtmp           librtmp - RTMP implementation
➜  ~  pkg-config --exists librtmp && echo "found" || echo "not found" 
found
Contributor

2bits commented Oct 18, 2012

what happens if you add --env=std to the install command?

stuarts commented Oct 18, 2012

Yep, that did it. Thanks. What was the issue?

Contributor

2bits commented Oct 18, 2012

Not certain. I'm certain that the formula needs a dependency on pkg-config though, as you've shown it uses it to find librtmp. So I'll adjust the formula. You can test that if you want.

Owner

MikeMcQuaid commented Oct 18, 2012

On 18 Oct 2012, at 21:30, 2bits notifications@github.com wrote:

Not certain. I'm certain that the formula needs a dependency on pkg-config though, as you've shown it uses it to find librtmp. So I'll adjust the formula. You can test that if you want.

My bad. Make it conditional on rtmpdump being requested please. Thanks!

stuarts commented Oct 18, 2012

Good luck pushing :)

Stuart Strader

On Thursday, October 18, 2012 at 1:33 PM, Mike McQuaid wrote:

On 18 Oct 2012, at 21:30, 2bits <notifications@github.com (mailto:notifications@github.com)> wrote:

Not certain. I'm certain that the formula needs a dependency on pkg-config though, as you've shown it uses it to find librtmp. So I'll adjust the formula. You can test that if you want.

My bad. Make it conditional on rtmpdump being requested please. Thanks!


Reply to this email directly or view it on GitHub (mxcl#15260 (comment)).

Contributor

adamv commented Oct 23, 2012

I added pkg-config as a dep to ffmpeg; try brew update and install again.

@adamv adamv closed this Oct 23, 2012

@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.