Git 1.7.12.3 failed to build on 10.8.2 #15451

Closed
ncocacola opened this Issue Oct 14, 2012 · 1 comment

Comments

Projects
None yet
1 participant

==> Upgrading git
==> Downloading http://git-core.googlecode.com/files/git-1.7.12.3.tar.gz
Already downloaded: /Library/Caches/Homebrew/git-1.7.12.3.tar.gz
==> make prefix=/usr/local/Cellar/git/1.7.12.3 CC=cc CFLAGS= LDFLAGS= install
echo ' rm -f "$(DESTDIR)/usr/local/Cellar/git/1.7.12.3/lib/Error.pm"' >> perl.mak
'/usr/bin/perl' -MError -e 'exit($Error::VERSION < 0.15009)' ||
echo ' cp private-Error.pm "$(DESTDIR)/usr/local/Cellar/git/1.7.12.3/lib/Error.pm"' >> perl.mak
echo instlibdir: >> perl.mak
echo ' echo /usr/local/Cellar/git/1.7.12.3/lib' >> perl.mak

Error: git did not build
Logs: /Users/***/Library/Logs/Homebrew/git/
Help: https://github.com/mxcl/homebrew/wiki/troubleshooting
mxcl#11481
mxcl#14423
mxcl#14585

ncocacola closed this Oct 14, 2012

I removed the unbrewed dylibs, la and pc suggested by brew doctor and it worked.

xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.