This repository has been archived by the owner. It is now read-only.

gnuplot + pango/cairo: font too small #16305

Closed
jtakimoto opened this Issue Nov 29, 2012 · 5 comments

Comments

Projects
None yet
3 participants
@jtakimoto

I installed gnuplot (with cairo+pango+wxWidgets), but any of the cairo-based terminals
(wxt, pngcairo, pdfcairo) doesn't work properly. If I try

gnuplot> set term wxt font "Times,12"
gnuplot> plot sin(x)

then no label is drawn in the plot because fonts are too small (using other fonts doesn't help). I can get normal output only if I use very large fontscale, for example

gnuplot> set term wxt fontscale 20
gnuplot> replot

Could anyone confirm this?
I first installed gnuplot by myself on OSX 10.8, and then installed via Homebrew on OSX 10.6. Both behave similarly.

I've reported this problem to the following gnuplot Traker Support Request #3589100
https://sourceforge.net/tracker/?group_id=2055&atid=202055
but haven't got any help yet.

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Jan 7, 2013

Contributor

Should we pull that pango commit referenced in the bug report?

Contributor

adamv commented Jan 7, 2013

Should we pull that pango commit referenced in the bug report?

@matteoipri

This comment has been minimized.

Show comment Hide comment
@matteoipri

matteoipri Jan 15, 2013

Contributor

pango 1.32.4 (http://ftp.gnome.org/pub/GNOME/sources/pango/1.32/pango-1.32.4.news) fixes this bug, that's the same bug as mxcl#11901
since we now have pango 1.32.6, I changed the pango formula, upgraded to 1.32.6 and got another bug.
thus, I tried pango 1.32.5 and it seems to work just fine with gnuplot.
This is my solution. I'll try to report the new bug to the pango community.

Contributor

matteoipri commented Jan 15, 2013

pango 1.32.4 (http://ftp.gnome.org/pub/GNOME/sources/pango/1.32/pango-1.32.4.news) fixes this bug, that's the same bug as mxcl#11901
since we now have pango 1.32.6, I changed the pango formula, upgraded to 1.32.6 and got another bug.
thus, I tried pango 1.32.5 and it seems to work just fine with gnuplot.
This is my solution. I'll try to report the new bug to the pango community.

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Jan 15, 2013

Contributor

Update to Pango is pending: #16900.

Contributor

adamv commented Jan 15, 2013

Update to Pango is pending: #16900.

@matteoipri

This comment has been minimized.

Show comment Hide comment
@matteoipri

matteoipri Jan 15, 2013

Contributor

Uh oh, I didn't search for it! I'm sorry and thank you!

Contributor

matteoipri commented Jan 15, 2013

Uh oh, I didn't search for it! I'm sorry and thank you!

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Jan 30, 2013

Contributor

Closing as an upstream bug.

Contributor

adamv commented Jan 30, 2013

Closing as an upstream bug.

@adamv adamv closed this Jan 30, 2013

@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.