This repository has been archived by the owner. It is now read-only.

Error: no such file to load -- stringio #16882

Closed
sushengloong opened this Issue Jan 4, 2013 · 6 comments

Comments

Projects
None yet
3 participants

Hi,

Have tried uninstalling and installing for many times but to no avail. Can someone help? Thanks!

brew doctor and brew --config output:-
https://gist.github.com/4450235

Contributor

adamv commented Jan 7, 2013

Does installing something work or not? Is it just brew doctor that fails?

Contributor

mistydemeo commented Jan 7, 2013

Did you change anything about the version of ruby that comes with your OS? stringio is a standard part of ruby.

Thanks for the replies!

@adamv brew install fails as well but brew update works. Strange.
@mistydemeo Right, I don't know what'd happened before I started using my company iMac. In that case, is it possible to use rvm ruby to run brew?

Contributor

adamv commented Jan 8, 2013

We don't support using rvm; Homebrew expects a normal healthy System ruby to be where Apple installs it to.

Thanks @adamv. Guess I will have to reinstall system ruby but any reason why rvm is not supported?

Contributor

adamv commented Jan 8, 2013

(A) we hard-code #! lines to the System ruby to guarantee a known Ruby version. (B) some versions of rvm build Ruby without environ defined, or with other odd errors.

@adamv adamv closed this Jan 11, 2013

@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.