This repository has been archived by the owner. It is now read-only.

csync fails to build (samba) #18620

Closed
mistydemeo opened this Issue Mar 20, 2013 · 5 comments

Comments

Projects
None yet
2 participants
@mistydemeo
Contributor

mistydemeo commented Mar 20, 2013

csync fails to build when trying to use our samba. From the build logs:

/tmp/csync-x1Yh/csync-0.49.9/modules/csync_smb.c: In function ‘_utimes’:
/tmp/csync-x1Yh/csync-0.49.9/modules/csync_smb.c:399: error: passing argument 2 of ‘smbc_utimes’ from incompatible pointer type
make[2]: *** [modules/CMakeFiles/csync_smb.dir/csync_smb.c.o] Error 1
make[1]: *** [modules/CMakeFiles/csync_smb.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking C executable csync
[100%] Built target csync_client
make: *** [all] Error 2

samba is non-optional in the current stable version of csync. I went back and installed each version of samba in brew versions and none of them worked.

Full logs: https://gist.github.com/mistydemeo/e5ee410757fe99b465a6

@mistydemeo

This comment has been minimized.

Show comment Hide comment
@mistydemeo

mistydemeo Mar 20, 2013

Contributor

This is on 10.6.8, Xcode 3.2.6.

Contributor

mistydemeo commented Mar 20, 2013

This is on 10.6.8, Xcode 3.2.6.

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Jun 18, 2013

Contributor

If this no longer works it should be redacted or moved to the boneyard.

Contributor

adamv commented Jun 18, 2013

If this no longer works it should be redacted or moved to the boneyard.

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Jun 22, 2013

Contributor

Should we redact this?

Contributor

adamv commented Jun 22, 2013

Should we redact this?

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Aug 17, 2013

Contributor

0.50.0 was released recently; csync should be updated

Contributor

adamv commented Aug 17, 2013

0.50.0 was released recently; csync should be updated

@adamv

This comment has been minimized.

Show comment Hide comment
@adamv

adamv Aug 17, 2013

Contributor

Much to my surprise, a clean build worked for me today on Snow Leopard / Xcode 3.2.6. Not saying it still doesn't have issues, but going to close this issue and try to update to 0.50.0.

Contributor

adamv commented Aug 17, 2013

Much to my surprise, a clean build worked for me today on Snow Leopard / Xcode 3.2.6. Not saying it still doesn't have issues, but going to close this issue and try to update to 0.50.0.

@adamv adamv closed this Aug 17, 2013

@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.