This repository has been archived by the owner. It is now read-only.

rrdtool fails to graph on OS X 10.8.3 #18641

Closed
edufelipe opened this Issue Mar 21, 2013 · 4 comments

Comments

Projects
None yet
4 participants

When trying to run the rrdtool graph command it fails with glib error.

$ rrdtool graph storage-1d.png --start -1d --imgformat PNG DEF:used=storage.rrd:used:AVERAGE AREA:used#f3876b:"Used":STACK

(process:70993): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()

(process:70993): GLib-CRITICAL **: void g_once_init_leave(volatile void *, gsize): assertion `result != 0' failed

(process:70993): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()

(process:70993): GLib-CRITICAL **: void g_once_init_leave(volatile void *, gsize): assertion `result != 0' failed

(process:70993): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()

(process:70993): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()

The same command, using the same rrdtool version on Ubuntu runs just fine.

Here are the outputs of the required commands:

$ brew doctor
Your system is raring to brew.

$ brew --config
HOMEBREW_VERSION: 0.9.4
ORIGIN: https://github.com/mxcl/homebrew
HEAD: 890897c6a250cc8b41284e4ab2d35d92f3dad643
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: dual-core 64-bit penryn
OS X: 10.8.3-x86_64
Xcode: 4.6.1
CLT: 4.6.0.0.1.1358221012
LLVM-GCC: build 2336
Clang: 4.2 build 425
X11: 2.7.4 => /opt/X11
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
Contributor

jacknagel commented Mar 23, 2013

I can reproduce it on 10.6 too. However I have no idea if it's Homebrew's fault nor how to debug it, so we'll need an upstream bug report here.

I did brew update && brew upgrade, still has the same problem.

rindek commented Mar 29, 2013

I had same issue, and asked rrdtool guys about it and got the answer oetiker/rrdtool-1.x#374 this patch made graphs working for me

Contributor

jacknagel commented Apr 1, 2013

This seems to have been fixed by the recent glib 2.36 update; at least, I can no longer reproduce it.

@jacknagel jacknagel closed this Apr 1, 2013

@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.