This repository has been archived by the owner. It is now read-only.

wxmac on 10.9.2 fails to install completely #28583

Closed
tclancy opened this Issue Apr 21, 2014 · 3 comments

Comments

2 participants
@tclancy

tclancy commented Apr 21, 2014

Running brew install --python wxmac --devel on 10.9.2 finishes successfully, but as best I understand, it fails to install the code directory that can be symlinked/ pathed to for virtualenvs: I expected to see a /python directory under /usr/local/Cellar/wxmac/3.0.0/lib/ but all that's there is a wx directory and a number of lib files.

There's no log or directory for wxmac under ~/Library/Logs/Homebrew/. Install log and my system info are here.

Apologies if this is a misunderstanding on my part about how WX works with Homebrew-installed Python.

@mistydemeo

This comment has been minimized.

Show comment
Hide comment
@mistydemeo

mistydemeo Apr 21, 2014

Contributor

wxmac and wxpython are separate formulae; if you want the python bindings, you can brew install wxpython. (That marks wxmac as a dependency, so if you didn't already have it installed it'll install it for you.)

Note also that there's no --devel or --python option for wxmac.

Contributor

mistydemeo commented Apr 21, 2014

wxmac and wxpython are separate formulae; if you want the python bindings, you can brew install wxpython. (That marks wxmac as a dependency, so if you didn't already have it installed it'll install it for you.)

Note also that there's no --devel or --python option for wxmac.

@mistydemeo mistydemeo closed this Apr 21, 2014

@tclancy

This comment has been minimized.

Show comment
Hide comment
@tclancy

tclancy Apr 21, 2014

Thanks and sorry about that. The notes I'd seen made it sound like wxmac was a wrapper. They also treated those flags as magic incantations, so I should have looked a little harder.

tclancy commented Apr 21, 2014

Thanks and sorry about that. The notes I'd seen made it sound like wxmac was a wrapper. They also treated those flags as magic incantations, so I should have looked a little harder.

@mistydemeo

This comment has been minimized.

Show comment
Hide comment
@mistydemeo

mistydemeo Apr 21, 2014

Contributor

No worries! They may have been outdated.

We did previously package wxmac and wxpython together; they were broken up for various reasons - they're actually separate projects with their own release schedules, and bundling them together prevented us from shipping binary packages for wxmac.

wxmac did previously provide both 2.8 and 2.9, with 2.9 as the --devel version, but we changed to packaging 2.9 as the stable version in the formula two years ago (and since then 3.0 came out).

Contributor

mistydemeo commented Apr 21, 2014

No worries! They may have been outdated.

We did previously package wxmac and wxpython together; they were broken up for various reasons - they're actually separate projects with their own release schedules, and bundling them together prevented us from shipping binary packages for wxmac.

wxmac did previously provide both 2.8 and 2.9, with 2.9 as the --devel version, but we changed to packaging 2.9 as the stable version in the formula two years ago (and since then 3.0 came out).

@Homebrew Homebrew locked and limited conversation to collaborators Feb 17, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.