pandoc bottle requires gcc 4.8.3_1 #31195

Closed
sjackman opened this Issue Jul 28, 2014 · 13 comments

Projects

None yet

5 participants

@sjackman
Member

The pandoc Mavericks bottle requires gcc 4.8.3_1, but the current bottled version of gcc is 4.9.1. Installing the 4.8.3_1 bottle of gcc resolves the issue.

$ brew install pandoc
$ otool -L /usr/local/bin/pandoc |grep gcc
    /usr/local/Cellar/gcc/4.8.3_1/lib/gcc/x86_64-apple-darwin13.2.0/4.8.3/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
$ ls /usr/local/Cellar/gcc/4.8.3_1/lib/gcc/x86_64-apple-darwin13.2.0/4.8.3/libgcc_s.1.dylib
ls: /usr/local/Cellar/gcc/4.8.3_1/lib/gcc/x86_64-apple-darwin13.2.0/4.8.3/libgcc_s.1.dylib: No such file or directory
$ brew install gcc-4.8.3_1.mavericks.bottle.1.tar.gz
$ ls /usr/local/Cellar/gcc/4.8.3_1/lib/gcc/x86_64-apple-darwin13.2.0/4.8.3/libgcc_s.1.dylib
/usr/local/Cellar/gcc/4.8.3_1/lib/gcc/x86_64-apple-darwin13.2.0/4.8.3/libgcc_s.1.dylib
@DomT4
Contributor
DomT4 commented Jul 29, 2014

Is this a dupe of this or a separate issue?

@sjackman
Member

New issue, same solution. The bottle revision of pandoc needs to be bumped to force a rebuild.

@sjackman
Member

Also applies to any other package that is compiled with ghc.

$ brew uses ghc
cabal-install       darcs       haskell-platform    pandoc-citeproc
cgrep           git-annex       pandoc          shellcheck
@rob-p
rob-p commented Jul 29, 2014

I'm seeing the same issue under yosemite. What's the proposed solution?

@sjackman
Member

The proposed solution is to rebuild a new revision of the bottle.
A workaround is brew --build-from-source pandoc.

@DomT4
Contributor
DomT4 commented Jul 29, 2014

Alright. If the bottles need redoing I think @mikemcquaid is the guy for that. Exercising the build from source option will resolve the issue for now, if you can put up with the slightly longer compile times.

@rob-p
rob-p commented Jul 29, 2014

I see. I'm actually encountering an issue even earlier in the dependency chain, when trying to compile ghc. I tried to install ghc itself with the --build-from-source option, but I end up running into the same issue:

==> Downloading http://www.haskell.org/ghc/dist/7.6.3/ghc-7.6.3-src.tar.bz2
Already downloaded: /Library/Caches/Homebrew/ghc-7.6.3.tar.bz2
==> Patching
patching file includes/HsFFI.h
patching file rts/RtsProbes.d
patching file utils/mkdirhier/mkdirhier.sh
==> Downloading http://www.haskell.org/ghc/dist/7.4.2/ghc-7.4.2-x86_64-apple-darwin.tar.bz2
Already downloaded: /Library/Caches/Homebrew/ghc--binary-7.4.2.tar.bz2
==> ./configure --prefix=/private/tmp/ghc-TH87/ghc-7.6.3/subfo --with-gcc=/usr/local/bin/gcc-4.9
configure: XCode version component 2: 1
checking for gcc... /usr/local/bin/gcc-4.9
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

READ THIS: https://github.com/Homebrew/homebrew/wiki/troubleshooting

These open issues may also help:
ghc: fix testsuite, compile problem (https://github.com/Homebrew/homebrew/pull/30610)
ghc 7.8.2 dynamic linking problem (https://github.com/Homebrew/homebrew/issues/29241)
ghc --devel failed to build on 10.9.2 (https://github.com/Homebrew/homebrew/issues/30000)

But I have no idea what would cause the C compiler cannot create executable error.

@DomT4
Contributor
DomT4 commented Jul 29, 2014

Strange. What's your brew config?

@rob-p
rob-p commented Jul 29, 2014

My brew config is as follows:

HOMEBREW_VERSION: 0.9.5
ORIGIN: https://github.com/Homebrew/homebrew
HEAD: 879e3ba1fdca48cbfc21a1cb0ca6ad64c28a1434
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: quad-core 64-bit arrandale
OS X: 10.10-x86_64
Xcode: 5.1.1
CLT: 6.0.0.0.1.1405597879
Clang: 5.1 build 503
MacPorts/Fink: /opt/local/bin/port
X11: 2.7.6 => /opt/X11
System Ruby: 2.0.0-481
Perl: /opt/local/bin/perl => /opt/local/bin/perl5.12
Python: /opt/local/bin/python => /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7
Ruby: /opt/local/bin/ruby
@mistydemeo
Contributor

@rob-p Your issue looks unrelated - mind opening a new issue with the output requested from the troubleshooting page? Thanks!

@DomT4
Contributor
DomT4 commented Jul 29, 2014

@rob-p - You probably want to be using Xcode 6 with 10.10. The two are intended to compliment each other and 5.1.1 isn't really intended for Yosemite. I'd recommend updating to the Xcode beta, and downloading the applicable CLT for those and trying again.

@rob-p
rob-p commented Jul 29, 2014

Thanks --- I'll give that a try and report back if it works.

Consider sending me encrypted and/or signed e-mail in the future using my
public key
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xAEC534A530C7BC76.

On Mon, Jul 28, 2014 at 9:30 PM, Dominyk Tiller notifications@github.com
wrote:

@rob-p https://github.com/rob-p - You probably want to be using Xcode 6
with 10.10. The two are intended to compliment each other and 5.1.1 isn't
really intended for Yosemite. I'd recommend updating to the Xcode beta, and
downloading the applicable CLT for those and trying again.


Reply to this email directly or view it on GitHub
#31195 (comment).

@MikeMcQuaid
Member

Fix ongoing in #31207.

@aerickson aerickson added a commit to aerickson/homebrew that referenced this issue Aug 3, 2014
@BrewTestBot @aerickson BrewTestBot + aerickson pandoc: update 1.12.4.2_1 bottle.
Closes #31195.
ec89f14
@xu-cheng xu-cheng locked and limited conversation to collaborators Feb 17, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.