This repository has been archived by the owner. It is now read-only.

ImageMagick on Lion Library not loaded #6891

Closed
l4u opened this Issue Aug 9, 2011 · 15 comments

Comments

@l4u
Contributor

l4u commented Aug 9, 2011

imagemagick was installed on Lion with Xcode 4.1

but identify and convert show a warning that liblcms wasn't loaded

$ identify
dyld: Library not loaded: /usr/local/lib/liblcms.1.0.19.dylib
Referenced from: /usr/local/bin/identify
Reason: image not found
Trace/BPT trap: 5

$ ls -l /usr/local/lib/liblcms*
ls: /usr/local/lib/liblcms*: No such file or directory

but little-cms was installed

@l4u

This comment has been minimized.

Show comment
Hide comment
@l4u

l4u Aug 9, 2011

Contributor

it seems working after uninstalling little-cms and imagemagick
and then install imagemagick again

Contributor

l4u commented Aug 9, 2011

it seems working after uninstalling little-cms and imagemagick
and then install imagemagick again

@zedtux

This comment has been minimized.

Show comment
Hide comment
@zedtux

zedtux Aug 11, 2011

Contributor

I confirm this bug !

I was encountering the same issue than you, and I did what you said:

brew remove little-cms --force
brew remove imagemagick
brew install imagemagick

Then everything back working !

Contributor

zedtux commented Aug 11, 2011

I confirm this bug !

I was encountering the same issue than you, and I did what you said:

brew remove little-cms --force
brew remove imagemagick
brew install imagemagick

Then everything back working !

@adamv adamv closed this Aug 11, 2011

@mattsnider

This comment has been minimized.

Show comment
Hide comment
@mattsnider

mattsnider Dec 13, 2011

Not sure if anyone else had this problem, but I also had to remove libtiff:

brew remove little-cms --force
brew remove libtiff --force
brew remove imagemagick
brew install imagemagick

mattsnider commented Dec 13, 2011

Not sure if anyone else had this problem, but I also had to remove libtiff:

brew remove little-cms --force
brew remove libtiff --force
brew remove imagemagick
brew install imagemagick

@acadavid

This comment has been minimized.

Show comment
Hide comment
@acadavid

acadavid Dec 13, 2011

I also had to remove libjpeg

brew remove little-cms --force
brew remove libtiff --force
brew remove libjpeg --force
brew remove imagemagick
brew install imagemagick

acadavid commented Dec 13, 2011

I also had to remove libjpeg

brew remove little-cms --force
brew remove libtiff --force
brew remove libjpeg --force
brew remove imagemagick
brew install imagemagick
@pal

This comment has been minimized.

Show comment
Hide comment
@pal

pal Feb 2, 2012

None of those fixes worked for me unfortunately, still get that error. Any ideas?

pal commented Feb 2, 2012

None of those fixes worked for me unfortunately, still get that error. Any ideas?

@kubido

This comment has been minimized.

Show comment
Hide comment
@kubido

kubido Feb 3, 2012

It's still getting error.. liblcms is installed, but when I locate it.. it always return :
/usr/local/lib/liblcms: No such file or directory

kubido commented Feb 3, 2012

It's still getting error.. liblcms is installed, but when I locate it.. it always return :
/usr/local/lib/liblcms: No such file or directory

@LouisStAmour

This comment has been minimized.

Show comment
Hide comment
@LouisStAmour

LouisStAmour Feb 6, 2012

sudo link the packages that come with imagemagick as well as imagemagick itself... worked for me!

LouisStAmour commented Feb 6, 2012

sudo link the packages that come with imagemagick as well as imagemagick itself... worked for me!

@kubido

This comment has been minimized.

Show comment
Hide comment
@kubido

kubido Feb 7, 2012

Hi Louis.. it's worked now!
I just linked the libjpeg package with brew: sudo brew link jpeg
thanks!

kubido commented Feb 7, 2012

Hi Louis.. it's worked now!
I just linked the libjpeg package with brew: sudo brew link jpeg
thanks!

@pal

This comment has been minimized.

Show comment
Hide comment
@pal

pal Feb 19, 2012

Yeah, sudo-linking littlecms was needed for me as well

pal commented Feb 19, 2012

Yeah, sudo-linking littlecms was needed for me as well

@ysiadf

This comment has been minimized.

Show comment
Hide comment
@ysiadf

ysiadf Feb 28, 2012

This thread just unstuck me after 3 hours of wheel-spinning. Thanks!

ysiadf commented Feb 28, 2012

This thread just unstuck me after 3 hours of wheel-spinning. Thanks!

@sgleadow

This comment has been minimized.

Show comment
Hide comment
@sgleadow

sgleadow Mar 3, 2012

sudo-ing the link steps worked for me.

brew install imagemagick
sudo brew link little-cms
sudo brew link imagemagick
sudo brew link libtiff
sudo brew link jpeg

sgleadow commented Mar 3, 2012

sudo-ing the link steps worked for me.

brew install imagemagick
sudo brew link little-cms
sudo brew link imagemagick
sudo brew link libtiff
sudo brew link jpeg

@dbwest

This comment has been minimized.

Show comment
Hide comment
@dbwest

dbwest Apr 29, 2012

sudo brew linking is not working for me anymore

dbwest commented Apr 29, 2012

sudo brew linking is not working for me anymore

@masterkain

This comment has been minimized.

Show comment
Hide comment
@masterkain

masterkain Apr 30, 2012

On Snow Leopard:

[ruby-1.9.2-p290] 09:25 ~ $ brew install imagemagick
==> Installing imagemagick dependency: little-cms
==> Downloading http://www.littlecms.com/1/lcms-1.19.tar.gz
Already downloaded: /Library/Caches/Homebrew/little-cms-1.19.tar.gz
==> ./configure --prefix=/usr/local/Cellar/little-cms/1.19 --disable-debug
==> make install
/usr/local/Cellar/little-cms/1.19: 21 files, 852K, built in 37 seconds
==> Installing imagemagick
==> Downloading https://downloads.sf.net/project/machomebrew/Bottles/imagemagick-6.7.5-7.snowleopard.bottle.tar.gz
Already downloaded: /Library/Caches/Homebrew/imagemagick-6.7.5-7.snowleopard.bottle.tar.gz
==> Pouring imagemagick-6.7.5-7.snowleopard.bottle.tar.gz
==> Caveats
Some tools will complain unless the ghostscript fonts are installed to:
  /usr/local/share/ghostscript/fonts
==> Summary
/usr/local/Cellar/imagemagick/6.7.5-7: 1396 files, 32M

[ruby-1.9.2-p290] 09:26 ~ $ identify
dyld: Library not loaded: /usr/local/lib/liblcms2.2.dylib
  Referenced from: /usr/local/bin/identify
  Reason: image not found
Trace/BPT trap

masterkain commented Apr 30, 2012

On Snow Leopard:

[ruby-1.9.2-p290] 09:25 ~ $ brew install imagemagick
==> Installing imagemagick dependency: little-cms
==> Downloading http://www.littlecms.com/1/lcms-1.19.tar.gz
Already downloaded: /Library/Caches/Homebrew/little-cms-1.19.tar.gz
==> ./configure --prefix=/usr/local/Cellar/little-cms/1.19 --disable-debug
==> make install
/usr/local/Cellar/little-cms/1.19: 21 files, 852K, built in 37 seconds
==> Installing imagemagick
==> Downloading https://downloads.sf.net/project/machomebrew/Bottles/imagemagick-6.7.5-7.snowleopard.bottle.tar.gz
Already downloaded: /Library/Caches/Homebrew/imagemagick-6.7.5-7.snowleopard.bottle.tar.gz
==> Pouring imagemagick-6.7.5-7.snowleopard.bottle.tar.gz
==> Caveats
Some tools will complain unless the ghostscript fonts are installed to:
  /usr/local/share/ghostscript/fonts
==> Summary
/usr/local/Cellar/imagemagick/6.7.5-7: 1396 files, 32M

[ruby-1.9.2-p290] 09:26 ~ $ identify
dyld: Library not loaded: /usr/local/lib/liblcms2.2.dylib
  Referenced from: /usr/local/bin/identify
  Reason: image not found
Trace/BPT trap
@masterkain

This comment has been minimized.

Show comment
Hide comment
@masterkain

masterkain Apr 30, 2012

In order to make it work I had to:

brew install lcms2
brew install fftw
brew install xz

masterkain commented Apr 30, 2012

In order to make it work I had to:

brew install lcms2
brew install fftw
brew install xz
@oesah

This comment has been minimized.

Show comment
Hide comment
@oesah

oesah Jun 9, 2015

brew unlink libtiff && brew link libtiff

worked for me on Mac OSX Mavericks.

oesah commented Jun 9, 2015

brew unlink libtiff && brew link libtiff

worked for me on Mac OSX Mavericks.

@Homebrew Homebrew locked and limited conversation to collaborators Jun 9, 2015

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.