Skip to content
This repository has been archived by the owner. It is now read-only.

Initial Formula for Vert.x #12227

Closed
wants to merge 3 commits into from
Closed

Initial Formula for Vert.x #12227

wants to merge 3 commits into from

Conversation

@CedricGatay
Copy link
Contributor

@CedricGatay CedricGatay commented May 13, 2012

Initial Formula for Vert.x, the polyglot effortless application development environment.

Initial Formula for Vert.x, the polyglot effortless application development environment.
@adamv
Copy link
Contributor

@adamv adamv commented Sep 9, 2012

I get:

$ vertx 
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/vertx/java/deploy/impl/cli/Starter : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

@adamv
Copy link
Contributor

@adamv adamv commented Sep 9, 2012

Going to 1.2.3 gives me: Error: bin does not exist

@adamv
Copy link
Contributor

@adamv adamv commented Sep 9, 2012

Current page lists: JDK. Vert.x requires JDK 1.7.0 or later.

@adamv
Copy link
Contributor

@adamv adamv commented Sep 25, 2012

@jacknagel @mxcl @MikeMcQuaid Presumably we have no problem per-se with including Java stuff that requires JDK 1.7.x, right?

@MikeMcQuaid
Copy link
Member

@MikeMcQuaid MikeMcQuaid commented Sep 25, 2012

No problem per-se but what OSX versions does this mean it can run on? Probably not in core as a result.

@mistydemeo
Copy link
Member

@mistydemeo mistydemeo commented Sep 25, 2012

Should add a Java17Requirement.

class Java17Requirement < Requirement
  def message; <<-EOS.undent
    Vert.x requires JDK 1.7.0 or later.
    EOS
  end

  def satisfied?
     `java -version 2>&1`.match(/\d\.\d/).to_s >= "1.7"
  end
end

(Not at my Lion box atm, not sure how that plays with its java placeholder executable.)

@adamv
Copy link
Contributor

@adamv adamv commented Sep 25, 2012

Non-fatal, I think we should allow it to be installed even if it can't be run until Java is updated.

@mistydemeo
Copy link
Member

@mistydemeo mistydemeo commented Sep 25, 2012

True, the message should make sure the user knows either way.

My main concern is that users might not see the messages printed during brew install, just the confusing message you saw when you tried to run the installed executable. If Vert.x let users know that they needed JDK 1.7.0 it would be easier for end users to debug.

@adamv adamv closed this in f4a2907 Sep 29, 2012
snakeyroc3 pushed a commit to snakeyroc3/homebrew that referenced this issue Dec 17, 2012
Closes Homebrew#12227.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
@Homebrew Homebrew locked and limited conversation to collaborators Feb 16, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

6 participants