gobby 0.4.94 #13422

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
4 participants
Contributor

2bits commented Jul 16, 2012

Upgrade gobby to version 0.4.94.
Add a dep on libunique so that it compiles.
Add a fails_with :clang because of a template issue.
Tested on Lion by running the gobby-0.5 graphical editor
after compiling with clang or llvm from XCode-4.3.3.

nibbles 2bits gobby 0.4.94
Upgrade gobby to version 0.4.94.
Add a couple of deps so that it compiles.
Add a `fails_with :clang` because of a template issue.
Tested on Lion by starting the gobby-0.5 graphical editor
after compiling with clang or llvm from XCode-4.3.3.
08e7099
Contributor

mistydemeo commented Jul 19, 2012

The updated version of libunique you submitted has a gtk+3 dep, but gobby looks to have a gtk+ dep a few levels down. I'm not able to get gtk+ and gtk+3 to link side-by-side (is that supposed to be possible?), so I can't get gobby to install if I have the updated libunique.

Contributor

2bits commented Jul 19, 2012

I was able to get gtk+ and gtk+3 to both install in that order a few days ago without any extra effort, but I agree it's evil those two deps. We could probably just stick with the libunique we used to have or remove the dep on libunique in Gobby. I don't know what it does, and it did not cause a build error. I just noticed cmake looking for it and it being not found.

Contributor

mistydemeo commented Jul 19, 2012

Aha, looks like there's only one file in common - gtk+ and gtk+3 both create a /usr/local/bin/gtk-update-icon-cache (on my system), preventing them from being linked alongside each other. Strange that didn't happen to you.

Contributor

2bits commented Jul 19, 2012

I think it did. I probably forced it to link.

Contributor

jacknagel commented Jul 19, 2012

Also a dependency tree that includes both gtk+ and gtk+3 seems likely result in other problems.

Contributor

adamv commented Sep 25, 2012

So what's the resolution here? Pass on this? Fix the dep tree?

Contributor

2bits commented Nov 14, 2012

Since gobby is at 0.4.94 already, I think I can close this.

2bits closed this Nov 14, 2012

xu-cheng locked and limited conversation to collaborators Feb 16, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.