Skip to content
This repository has been archived by the owner. It is now read-only.

Python26 #3432

Closed
wants to merge 1 commit into from
Closed

Python26 #3432

wants to merge 1 commit into from

Conversation

@bf4
Copy link
Contributor

@bf4 bf4 commented Nov 30, 2010

Readded the python26 formula from the history

@adamv
Copy link
Contributor

@adamv adamv commented Nov 30, 2010

(Note: Python 2.6.x is up to 2.6.6, unless you specifically want 2.6.5)

@MikeMcQuaid
Copy link
Member

@MikeMcQuaid MikeMcQuaid commented Nov 30, 2010

Python 2.6 is a system duplicate (on 10.6 at least).

@MikeMcQuaid
Copy link
Member

@MikeMcQuaid MikeMcQuaid commented Nov 30, 2010

And even on 10.5, I can't see the need to have it if we have 2.7.

@vorushin
Copy link

@vorushin vorushin commented Nov 30, 2010

I am a Pythonista and first what I looked at in Formulas/ was python versions available (and python_select tool). When I work with Google App Engine, I need python2.5, most django projects I do in python2.6 and I have python 2.7 to test and play.

@MikeMcQuaid
Copy link
Member

@MikeMcQuaid MikeMcQuaid commented Nov 30, 2010

That's reasonable but it also has the potential to break some of our other Python support and is easy for you to do it locally.

@adamv
Copy link
Contributor

@adamv adamv commented Nov 30, 2010

@MikeMcQuaid: Apple-provided Pythons always have "known issues" that clean builds don't.

@adamv
Copy link
Contributor

@adamv adamv commented Nov 30, 2010

People should check out Pythonbrew: https://github.com/utahta/pythonbrew

(And contribute patches there.)

Homebrew doesn't want to be in the business of managing multiple Python installs, or Ruby installs, hence RVM and Pythonbrew.

@bf4
Copy link
Contributor Author

@bf4 bf4 commented Dec 1, 2010

All good points.. perhaps we should do something about the brew install python message to mention pythonbrew. There are also compatibility issues with this patch working with other brews, so I rescind it.

@MikeMcQuaid
Copy link
Member

@MikeMcQuaid MikeMcQuaid commented Dec 1, 2010

I'd go further than that and say we should consider removing python altogether in favour of pythonbrew.

@bf4
Copy link
Contributor Author

@bf4 bf4 commented Dec 1, 2010

And perhaps mention https://github.com/gugod/App-perlbrew while we're at it..

I came across the issue when trying to install mercurial, and got the message

brew install mercurial
Mercurial can be install thusly:
brew install pip && pip install mercurial

I suppose we should update that as well.

@ghost
Copy link

@ghost ghost commented May 7, 2011

I agree, rvm and pythonbrew are much better for that kind of thing meaning ruby, python, python3, ruby-enterprise-edition, and rubinius could all be removed.

@Homebrew Homebrew locked and limited conversation to collaborators Feb 16, 2016
This pull request was closed.
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants