Skip to content

HughxDev/eslint-config-hughx

Repository files navigation

logo

eslint-config-hughx

Provides hughx’s JavaScript conventions as .eslintrc shared configs.
Emphasizes readability and ease of writing.

Downloads per month (NPM)


ℹ️ For TypeScript support, use eslint-config-hughx-ts instead.

Installation

npm versions 7 and above

npm install -D eslint-config-hughx

yarn and older npm

You will have to install peerDependencies manually:

# npm install -D
yarn add -D \
  eslint \
  eslint-config-airbnb-base \
  eslint-config-hughx \
  eslint-plugin-import

React projects

# npm install -D
yarn add -D \
  eslint \
  eslint-config-airbnb-base \
  eslint-config-hughx \
  eslint-plugin-import \
  eslint-plugin-jsx-a11y \
  eslint-plugin-react \
  eslint-plugin-react-hooks

Usage

Extend hughx in your project’s .eslintrc.js or equivalent:

module.exports = {
  "extends": [
    "hughx",
  ],
  // …
}

Eslint-config-hughx defaults to the latest version of JavaScript/ECMAScript at the time of release. If your transpiler isn’t set up for this (or you don’t use one), then you should override both env.es* and parserOptions.ecmaVersion, e.g.

// Downgrading from ES2021 to ES6
module.exports = {
  "extends": [
    "hughx",
  ],
  "env": {
    "es2021": false,
    "es6": true
  },
  "parserOptions": {
    "ecmaVersion": 6
  }
};

Environment-specific Configs

You can extend from one of the following to bring in sensible defaults for different use cases:

  • hughx/react
  • hughx/node
  • hughx/web-components

About

Provides hughx’s JavaScript conventions as .eslintrc shared configs. Emphasizes readability and ease of writing.

Resources

License

Stars

Watchers

Forks

Packages

No packages published