Skip to content

This change to the buildpack allows the cached and requested Swift binaries to run on CloudFoundry's cflinuxfs3 stack, which requires the Ubuntu 18.04 Swift binaries, as well as clang 8.0.0. It continues to use Swift 5.0 and cache 4.2.4.

This changes drops support for the Ubuntu 14.04 Swift binaries which were used to run on the cflinuxfs2 stack. Applications should see no difference between this version and 2.0.19 which includes the same versions of Swift.

Assets 3

@SwiftDevOps SwiftDevOps released this Apr 1, 2019

This buildpack keeps Swift 5.0 as the default version, but caches the recently released Swift 4.2.4.

Assets 3

@SwiftDevOps SwiftDevOps released this Mar 28, 2019

This release makes Swift 5.0 the default Swift version and caches the Swift 4.2.3 binaries.

It also contains a fix where required binaries for Swift 5.0 were not properly packaged upon download in previous releases.

Assets 3

@SwiftDevOps SwiftDevOps released this Mar 3, 2019

This release makes Swift 4.2.3 the default version of Swift and caches Swift 4.2.2.

Assets 3

@SwiftDevOps SwiftDevOps released this Dec 14, 2018

This release upgrades the default version of Swift to 4.2.1, and caches the 4.2 binaries.

Assets 3

@SwiftDevOps SwiftDevOps released this Sep 20, 2018

The version of the Swift Buildpack adds Swift 4.2 as the default version and caches Swift 4.1.3.

Assets 3

@SwiftDevOps SwiftDevOps released this Aug 3, 2018

This release upgrades the default Swift version to 4.1.3, with 4.1.2 cached. Swift 4.1.3 is a Linux-only release to address a problem with Decimal in the standard library. https://forums.swift.org/t/swift-4-1-3-is-released-linux-only/14847

Assets 3

@SwiftDevOps SwiftDevOps released this Jul 20, 2018

This buildpack release uses Swift 4.1.2 as the default swift version, and caches Swift 4.1.1 for quicker Swift application builds.

Assets 3

@SwiftDevOps SwiftDevOps released this May 10, 2018

This new release supports Swift 4.1.1 instead of Swift 4.1, addressing a security vulnerability in Swift 4.1 for Ubuntu 14.04. More details here: https://support.apple.com/en-us/HT208804

Assets 3
You can’t perform that action at this time.