New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Do not hide passwords and no generator #267

Closed
i-panov opened this Issue Dec 20, 2016 · 7 comments

Comments

Projects
None yet
2 participants
@i-panov

i-panov commented Dec 20, 2016

Even when I choose in the settings option "hide the password" password is not hidden. And I did not find in the program password generator. He does have?

@annejan annejan self-assigned this Dec 20, 2016

@annejan

This comment has been minimized.

Member

annejan commented Dec 20, 2016

Ah, yes .. #266 . . you are running current master branch which has some regression . .
One of the issues is not having a working pwgen implementation.

My best advice would be to compile (and install) the tagged 1.1.6 release.

make uninstall
make clean
git checkout v1.1.6 
make 
make install

The "hide password" and "password generator" do work fine in the tagged release.

Sorry for any inconvenience this might have caused @DarkByte2015 . . we are working really hard on the upcoming 1.2 release . . which has caused some collateral breakage.

@annejan

This comment has been minimized.

Member

annejan commented Dec 20, 2016

Related: #262

@i-panov

This comment has been minimized.

i-panov commented Dec 20, 2016

But it seems I have already version 1.1.6. I downloaded the file with the source code here.

@annejan

This comment has been minimized.

Member

annejan commented Dec 20, 2016

Ahhh .. sorry @DarkByte2015 .. I was assuming github master build . . you know what they say about assuming . .

I'll have a try with a Ubuntu 14.04 VM this evening to see if I can reproduce your issues..

@annejan

This comment has been minimized.

Member

annejan commented Dec 20, 2016

Have am trying a lot of things (qt4 and qt5 builds, using pwgen and built-in) not been able to reproduce your issues yet. Have come to the conclusion that the qt4 build is extremely ugly and nasty in parts . .

Quick questions:

  1. are you using pwgen or the built-in fallback password generator?
  2. did you build qtpass with qt4 or qt5?
  3. could you make a screenshot of your settings (or describe them, or share (parts of) the config file from $HOME/.config/IJHack/QtPass.conf )?
@annejan

This comment has been minimized.

Member

annejan commented Dec 20, 2016

@DarkByte2015 It seems the hide-password only works with Use template enabled in 1.1.6
Can you confirm that works? I don't know in which version this got broken.

As for the password generator I still can't get it to not work . .

@annejan annejan added the regression label Dec 20, 2016

@i-panov

This comment has been minimized.

i-panov commented Dec 27, 2016

I began to write you an answer and decided to check again. Very strange, I did not change anything, but it worked. Passwords are hidden as it should, and I even found a password generator. He works. By the way he might have been there before, I just did not notice it. I thought that there is a password generator separate window. As in example keepass.

@i-panov i-panov closed this Dec 27, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment