New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add to Linux brew #301

Closed
cFire opened this Issue Mar 7, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@cFire

cFire commented Mar 7, 2017

It would be nice to have the option to install via brew on Linux for non-privileged users or for installs to portable media.

@cFire

This comment has been minimized.

cFire commented Mar 7, 2017

Never mind, I'm an idiot and I did it wrong. It works fine :)

@cFire cFire closed this Mar 7, 2017

@cFire

This comment has been minimized.

cFire commented Mar 7, 2017

Nope, it fails after all because cask apparently doesn't work on linuxbrew anyway since it uses an osx dmg. So a linuxbrew version would still be nice to have after all.

@cFire cFire reopened this Mar 7, 2017

@annejan

This comment has been minimized.

Member

annejan commented Mar 7, 2017

I'll have a quick look, a source install should be possible too.

Will have a quick look at linux brew since I've never heard of it before.

@annejan

This comment has been minimized.

Member

annejan commented Mar 7, 2017

Apparently it should be easy for me to make a Qt5 build for QtPass on Linuxbrew
Linuxbrew/brew#1 (comment)

Currently on osboxes.org ubuntu image installed Linuxbrew and did brew install pass qt5

Both went pretty cleanly . . although did install a hell of a lot of stuf (from source) in it's resident folder . . I would probably never use this myself on a linux (where I am a big fan of brew on macOS since it doesn't have a native package manager outside of the app store)

@cFire

This comment has been minimized.

cFire commented Mar 8, 2017

linuxbrew is usually a bit of an edge-case solution anyway. In my case it would be useful to have it in brew for Ubuntu 14.04LTS machines since it's not in the 14.04 repos.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment