Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

QtPass does not detect GPG installation #50

Closed
evilstiefel opened this issue Jun 4, 2015 · 4 comments
Closed

QtPass does not detect GPG installation #50

evilstiefel opened this issue Jun 4, 2015 · 4 comments

Comments

@evilstiefel
Copy link

@evilstiefel evilstiefel commented Jun 4, 2015

When trying to start QtPass on my Windows 8.1 machine, I just get the message:

"Please install GnuPG on your system.
Install gpg using your favorite package manager
or download it from GnuPG.org"

The programm then does not display anything upon clicking Ok, the process just hangs in the background. On the first try, it did ask me about my password-store location, but then nothing happened.

When running the Windows command line window, gpg and gpg2 are valid commands.

I am running the most recent installation of GPG4Win.

@annejan
Copy link
Member

@annejan annejan commented Jun 4, 2015

I have personally done zero testing on windows, but this is a barely finished part of the new "first use wizard" I will dive into as soon as I have some time. I'll look into the environment variables I can use or other options for windows.

The older build https://github.com/IJHack/qtpass/releases/tag/v0.8.1 (or some revisions back) should work (when you set up the paths of the gpg executable etc).

@annejan
Copy link
Member

@annejan annejan commented Jun 9, 2015

On my pretty clean Win7 VM from modern.ie GPG4Win was autodetected.
I did get the popup, unfortunately, looking closer into this and will keep you updated on progress.
EDIT: Ah, apparently that was pure luck. Path is semi-colon separated on Windows, should be fixed in "develop" soon to be merged to master.

@annejan
Copy link
Member

@annejan annejan commented Jun 9, 2015

Have tried the new fixed version on two clean windows machines, does it now work for you?
https://github.com/IJHack/qtpass/releases/tag/v0.8.3

If you have any issues, feel free to re-open or open a fresh issue.

@stone1343
Copy link

@stone1343 stone1343 commented Mar 10, 2019

I know this thread is old, but this page was one of few hits that looked relevant when I searched...

I have the same issue, using a daily build of Lubuntu 19.04, I got the identical message but when I tried "sudo apt install gpg", I got "gpg is already the newest version"

I hope that helps

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants