New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SIGSEGV in MainWindow::executeWrapper on clean install #122

Closed
bearsh opened this Issue Dec 1, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@bearsh

bearsh commented Dec 1, 2015

Hi I get a SIGSEGV on a clean install (no ~/.password-store) in MainWindow::executeWrapper while calling autoclearTimer->stop();. autoclearTimer is not initialized and not null either. Here's the backtrace:

0   QObject::thread() const         0x7ffff705d9f8  
1   QObject::killTimer(int)         0x7ffff706302a  
2   QTimer::stop()          0x7ffff706bbe1  
3   MainWindow::executeWrapper  mainwindow.cpp  647 0x41ad60    
4   MainWindow::listKeys    mainwindow.cpp  1202    0x420931    
5   MainWindow::getSecretKeys   mainwindow.cpp  1376    0x4228f4    
6   ConfigDialog::wizard    configdialog.cpp    497 0x42f8e8    
7   MainWindow::config  mainwindow.cpp  403 0x417541    
8   MainWindow::checkConfig mainwindow.cpp  290 0x4154f9    
9   MainWindow::MainWindow  mainwindow.cpp  45  0x4118be    
10  main    main.cpp    44  0x41065d    

following patch fixes the issue:

diff --git a/mainwindow.cpp b/mainwindow.cpp
index 2955501..8205209 100644
--- a/mainwindow.cpp
+++ b/mainwindow.cpp
@@ -42,6 +42,7 @@ MainWindow::MainWindow(QWidget *parent)
   ui->statusBar->showMessage(tr("Welcome to QtPass %1").arg(VERSION), 2000);
   freshStart = true;
   startupPhase = true;
+  autoclearTimer = NULL;
   if (!checkConfig()) {
     // no working config
     QApplication::quit();
@@ -49,7 +50,6 @@ MainWindow::MainWindow(QWidget *parent)
   ui->copyPasswordButton->setEnabled(false);
   setClippedPassword("");
   QtPass = NULL;
-  autoclearTimer = NULL;
   QTimer::singleShot(10, this, SLOT(focusInput()));
 }

it only seems to happen when there's no ~/.password-store...
(sorry for being to lazy to create a pull request...)

@annejan

This comment has been minimized.

Member

annejan commented Dec 1, 2015

No worries, good catch, will patch tomorrow.
Thanks!

@annejan annejan closed this in 61d9558 Dec 2, 2015

annejan added a commit that referenced this issue Jun 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment