Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for Mac OS X (10.9, 10.10) #44

Closed
vielmetti opened this issue Apr 29, 2015 · 8 comments
Closed

Support for Mac OS X (10.9, 10.10) #44

vielmetti opened this issue Apr 29, 2015 · 8 comments

Comments

@vielmetti
Copy link

@vielmetti vielmetti commented Apr 29, 2015

bluepy and bluepy-helper depend on Linux's bluez.

It would be a useful thing to have an abstraction layer that let you write the same python code for both Mac OS X and Linux, along the lines of what noble does for node.js.

Tracking any specific issues here.

@hansmbakker

This comment has been minimized.

Copy link

@hansmbakker hansmbakker commented Mar 1, 2016

https://bitbucket.org/OscarAcena/pygattlib does this, you can have a look at how they integrated the OSX part and the abstraction layer there. I would also say that bluepy could improve upon this point - being cross platform would be a major advantage.

@mritchie712

This comment has been minimized.

Copy link

@mritchie712 mritchie712 commented Apr 10, 2016

@Wind-rider are you syaing pygattlib supports OSX? When I try to install it on OSX I get:

OSError: Not supported OS

Full error:

$ sudo pip install gattlib
Collecting gattlib
  Downloading gattlib-0.20150805.tar.gz (1.7MB)
    100% |████████████████████████████████| 1.7MB 205kB/s 
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 20, in <module>
      File "/private/tmp/pip-build-_Atfhk/gattlib/setup.py", line 48, in <module>
        raise OSError("Not supported OS")
    OSError: Not supported OS

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /private/tmp/pip-build-_Atfhk/gattlib
@hansmbakker

This comment has been minimized.

Copy link

@hansmbakker hansmbakker commented Apr 11, 2016

@mritchie712 I'm sorry, I must have confused it.

However here https://github.com/matthewelse/bleep/ says to have experimental OSX support besides Linux support, with two backends as shown in https://github.com/matthewelse/bleep/blob/master/bleep/backend.py.

This could be an example for bluepy?

@mritchie712

This comment has been minimized.

Copy link

@mritchie712 mritchie712 commented Apr 12, 2016

@Wind-rider that looks promising, thanks!

@bretcj7

This comment has been minimized.

Copy link

@bretcj7 bretcj7 commented Dec 19, 2017

@mritchie712 did you get past the issue? I'm battling the same right now.

@mritchie712

This comment has been minimized.

Copy link

@mritchie712 mritchie712 commented Dec 19, 2017

No, I ended up using ionic (JavaScript framework) instead

@undera undera mentioned this issue Dec 28, 2017
@IanHarvey

This comment has been minimized.

Copy link
Owner

@IanHarvey IanHarvey commented Jul 23, 2018

Realistically, Mac OS support isn't going to be added to Bluepy any time soon.

Interested parties might want to look at https://github.com/TheCellule/python-bleson, which supports Mac OS but is still somewhat under development.

@watsonix

This comment has been minimized.

Copy link

@watsonix watsonix commented Sep 21, 2018

Bummer but thanks for letting us know

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.