[dev.icinga.com #2573] Commands dropdown cannot be used repetitive #957

Closed
icinga-migration opened this Issue May 1, 2012 · 7 comments

Comments

Projects
None yet
1 participant
Member

icinga-migration commented May 1, 2012

This issue has been migrated from Redmine: https://dev.icinga.com/issues/2573

Created by mario@rimann.org on 2012-05-01 06:21:38 +00:00

Assignee: mario@rimann.org
Status: Closed (closed on 2012-05-13 17:25:22 +00:00)
Target Version: (none)
Last Update: 2014-12-08 09:42:42 +00:00 (in Redmine)

Icinga Version: 1.10.0
OS Version: any

When watching a list of services (e.g. http://[byIcingaServer]/icinga/cgi-bin/status.cgi?host=all&type=detail&servicestatustypes=29), I cannot select single services to e.g. force a re-check more than once in a row.

Steps to reproduce:

  • visit that page (which must show 2 or more entries at least)
  • mark the checkbox of one of the listed entries
  • select "Re-Schedule Next Service Check" from the commands dropdown just above the checkbox-column
  • click the submit button below the dropdown menu
  • on the page that gets shown, confirm the re-scheduling by clicking "commit"
  • on the confirmation page that gets shown, click "Done" which brings you back to the list that was shown at the beginning
  • (note that the checkbox is still set at this service)
  • now checking another service from the list to re-schedule it's next check is impossible since the entry "Re-Schedule Next Service Check" is already selected in the commands dropdown and the submit button is disabled.

Relations:

Member

icinga-migration commented May 1, 2012

Updated by mfriedrich on 2012-05-01 06:53:02 +00:00

please show

git log -1

Member

icinga-migration commented May 1, 2012

Updated by ricardo on 2012-05-01 11:13:55 +00:00

Hi,

this behavior changes with 1.7. The checkboxes and the DropDown menu get's reseted then. Because it depends on the type of browser where the checkboxes are still selected or not.

please check with current git master and test it if you can.

Cheers Ricardo

Member

icinga-migration commented May 5, 2012

Updated by mfriedrich on 2012-05-05 11:50:30 +00:00

Member

icinga-migration commented May 8, 2012

Updated by mario@rimann.org on 2012-05-08 20:25:40 +00:00

Well I've seen this behaviour in a 1.6.x installation - so this bug report might be outdated already.

Please close this issue then.

Member

icinga-migration commented May 8, 2012

Updated by mfriedrich on 2012-05-08 20:27:06 +00:00

try an icinga snapshot build for 1.7 :-)

http://build.icinga.org/snapshots/

Member

icinga-migration commented May 13, 2012

Updated by mfriedrich on 2012-05-13 17:25:22 +00:00

  • Status changed from Feedback to Closed
Member

icinga-migration commented Dec 8, 2014

Updated by mfriedrich on 2014-12-08 09:42:42 +00:00

  • Project changed from 19 to Core, Classic UI, IDOUtils
  • Category changed from 52 to Classic UI
  • Icinga Version set to 1
  • OS Version set to any
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment