[dev.icinga.com #2523] Applying changes to many hosts #749

Closed
icinga-migration opened this Issue Apr 13, 2012 · 8 comments

Projects

None yet

1 participant

@icinga-migration
Member

This issue has been migrated from Redmine: https://dev.icinga.com/issues/2523

Created by chjohnst on 2012-04-13 23:28:40 +00:00

Assignee: mhein
Status: Resolved (closed on 2012-04-30 19:07:58 +00:00)
Target Version: 1.7
Last Update: 2012-04-30 19:07:58 +00:00 (in Redmine)


If I have multiple hosts show up with a failed service, if I want to acknowledge all of them at once (click the bread crumb, etc) and then acknowledge it is only applying the acknowledgement to a single host when it should be applying to all. I think this is a bug. Same thing happens for downtime as well and other commands.

Attachments


Relations:

Member

Updated by mhein on 2012-04-16 06:41:03 +00:00

  • Target Version changed from 1.6.2 to 1.7
Member

Updated by mhein on 2012-04-16 06:41:47 +00:00

Scheduled for 1.7. Please do a cherry-picking downstream into r1.6.

Member

Updated by ossmon on 2012-04-16 07:02:11 +00:00

I think, same as #2406 and #2454

Member

Updated by Frankstar on 2012-04-17 11:45:48 +00:00

should be fixed ??
https://dev.icinga.org/issues/2416

which version did you use ?

Member

Updated by mhein on 2012-04-18 09:05:46 +00:00

  • Assigned to set to mhein
Member

Updated by mfriedrich on 2012-04-30 18:47:10 +00:00

  • File added icinga_web_hostlist_ack_command_svc_cmd_wrong_sent.png
  • Priority changed from Normal to High

that's not fixed.

for some awkward reason the host list and host ack with expiry time sends a service command ?!

icinga_web_hostlist_ack_command_svc_cmd_wrong_sent.png

Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;localhostv6;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'localhostv6' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;localhostv6-flexible;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'localhostv6-flexible' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;test_router_1;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'test_router_1' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;test_router_2;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'test_router_2' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;test_router_3;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'test_router_3' and service '0' provided in external command!
Member

Updated by mfriedrich on 2012-04-30 19:03:03 +00:00

see #2572 - fixed over here. now let's see for the rest.

Member

Updated by mfriedrich on 2012-04-30 19:07:58 +00:00

  • Status changed from New to Resolved
  • Priority changed from High to Normal
  • Done % changed from 0 to 100

ok works for me, as this is a duplicate of various issues as well, and the wrong command is a seperated issue.

@icinga-migration icinga-migration added this to the 1.7 milestone Jan 17, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment