Skip to content
This repository has been archived by the owner. It is now read-only.

[dev.icinga.com #3520] PostgreSQL-Sessionproblem #998

Closed
icinga-migration opened this issue Jan 5, 2013 · 3 comments

Comments

Projects
None yet
1 participant
@icinga-migration
Copy link
Member

commented Jan 5, 2013

This issue has been migrated from Redmine: https://dev.icinga.com/issues/3520

Created by dmikulski on 2013-01-05 18:47:17 +00:00

Assignee: (none)
Status: Rejected (closed on 2013-01-05 23:26:34 +00:00)
Target Version: (none)
Last Update: 2013-01-11 12:58:05 +00:00 (in Redmine)

Icinga Version: 1.8.3
Icinga Web Version: 1.8.1
IDO Version: 1.8.0
OS Version: CentOS 6.3
DB Type: PostgreSQL
DB Version: PostgreSQL 8.4.13 und mit 9.2
Browser Version: FireFox 17.0.1 und andere

Bei einem frisch installiertem CentOS6.3 mit einem PostgreSQL 8.4 Datenbank, IDOUtils und Icinga landet der Browser nach dem Login entweder sofort wieder im Anmeldefenster oder es kommt die Meldung "Your login session has gone away, press ok to login again!
" (siehe Screenshot).
Das selbe auf dem Live-Evaluierungssystem. Ab und zu klappt es, aber der Fehler taucht dann wieder unterwartet auf.

Auszug aus Icinga-Web Log:
[Sat Jan 5 18:18:03 2013] [fatal] Uncaught AppKitDoctrineException: User attribute is not a NsmUser! (/usr/local/icinga-web/app/modules/AppKit/lib/auth/AppKitSecurityUser.class.php:270)

Auszug aus Icinga-Web-Debug Log:
[Sat Jan 5 18:17:42 2013] [debug] Auth.Provider: Object (name=internal) initialized
[Sat Jan 5 18:17:42 2013] [debug] Auth.Provider: Object (name=auth_key) initialized
[Sat Jan 5 18:17:42 2013] [debug] Auth.Provider: Object (name=http-basic-authentication) initialized
[Sat Jan 5 18:17:42 2013] [debug] Auth.Provider.HTTPBasicAuthentification: Got data (auth_name=, auth_type=)
[Sat Jan 5 18:17:51 2013] [debug] Auth.Dispatch: Starting authenticate (username=root)
[Sat Jan 5 18:17:51 2013] [info] Auth.Dispatch: Converting username to lowercase
[Sat Jan 5 18:17:51 2013] [debug] Auth.Dispatch: Userdata found in db (uid=1)
[Sat Jan 5 18:17:51 2013] [debug] Auth.Provider: Object (name=internal) initialized
[Sat Jan 5 18:17:51 2013] [debug] Auth.Dispatch: Authoritative provider found (provider=internal, authid=root)
[Sat Jan 5 18:17:51 2013] [debug] Auth.Provider.Database: HASH (4f894bbda9717ecad7c3e37b5b6f35a5ffb9cf7dbb0388716945116312a1e141)
[Sat Jan 5 18:17:51 2013] [debug] Auth.Dispatch: Successfull authentication (provder=internal)
[Sat Jan 5 18:17:51 2013] [info] Auth.Dispatch: Delegate authentication (not_authoritative=internal,user=root)
[Sat Jan 5 18:17:51 2013] [debug] Auth.Provider: Object (name=auth_key) initialized
[Sat Jan 5 18:17:51 2013] [debug] Auth.Provider: Object (name=http-basic-authentication) initialized
[Sat Jan 5 18:17:51 2013] [debug] Auth.Dispatch: Delegate authentication, try http-basic-authentication (not_authoritative=internal,user=root)
[Sat Jan 5 18:17:51 2013] [debug] Auth.Dispatch: Delegate authentication, no providers found for root (not_authoritative=internal)
[Sat Jan 5 18:17:52 2013] [info] User root (Root, Enoch) logged in!
[Sat Jan 5 18:18:01 2013] [debug] Auth.Provider: Object (name=internal) initialized
[Sat Jan 5 18:18:01 2013] [debug] Auth.Provider: Object (name=auth_key) initialized
[Sat Jan 5 18:18:01 2013] [debug] Auth.Provider: Object (name=http-basic-authentication) initialized
[Sat Jan 5 18:18:01 2013] [debug] Auth.Provider.HTTPBasicAuthentification: Got data (auth_name=, auth_type=)

Im Web habe ich bereits Themen dazu gefunden (leider keine weiteren Feedbacks):
http://www.mail-archive.com/icinga-users@lists.sourceforge.net/msg01531.html

Debuggen kann ich das irgendwie auch nicht wirklich, bzw. wüsste nicht an welcher Stelle.

Im Moment muss ich für meine Vorgesetzten Monitorings evaluieren und das künftige Monitoring soll mit PostgreSQL laufen. Gibt es eine Möglichkeit das ich das vor dem nächsten Release mit ein paar Schritten selbst fixen kann?

Attachments

@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Jan 5, 2013

Updated by jmosshammer on 2013-01-05 23:26:34 +00:00

  • Status changed from New to Rejected

Hi,

sorry, I understand the bug report, but I have to reject this issue because we're an international project and our main language is english (and most ppl in the project team don't speak German). Please reopen it with an english bug description.

To offer you some help: Please try checking out my jmosshammer/1.8.2 branch by using
git clone git://git.icinga.org
git checkout -b jmosshammer/1.8.2 origin/jmosshammer/1.8.2

And give me feedback if the problem still occurs. If so, we gonna find a solution for it ;)

@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Jan 11, 2013

Updated by k0nstantin on 2013-01-11 06:27:42 +00:00

I had the same problem and when 1 have updated to jmosshammer/1.8.2 branch it resolved, but now i can't sometimes login to icinga-web first time. After i enter login and password and press "OK" i'm redirected to the same login page without any error. I have this message in icinga-web debug log:

_[Fri Jan 11 06:15:00 2013] [debug] Auth.Dispatch: Starting authenticate (username=root)
[Fri Jan 11 06:15:00 2013] [info] Auth.Dispatch: Converting username to lowercase
[Fri Jan 11 06:15:00 2013] [debug] Auth.Dispatch: Userdata found in db (uid=1)
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider: Object (name=internal) initialized
[Fri Jan 11 06:15:00 2013] [debug] Auth.Dispatch: Authoritative provider found (provider=internal, authid=root)
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider.Database: HASH (6a2c45f1ef39d8c98782c12061a8d059f447663b84209a495858570a1ac28fce)
[Fri Jan 11 06:15:00 2013] [debug] Auth.Dispatch: Successfull authentication (provder=internal)
[Fri Jan 11 06:15:00 2013] [info] Auth.Dispatch: Delegate authentication (not_authoritative=internal,user=root)
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider: Object (name=auth_key) initialized
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider: Object (name=http-basic-authentication) initialized
[Fri Jan 11 06:15:00 2013] [debug] Auth.Dispatch: Delegate authentication, try http-basic-authentication (not_authoritative=internal,user=root)
[Fri Jan 11 06:15:00 2013] [debug] Auth.Dispatch: Delegate authentication, no providers found for root (not_authoritative=internal)
[Fri Jan 11 06:15:00 2013] [info] User root (Root, Enoch) logged in!
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider: Object (name=internal) initialized
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider: Object (name=auth_key) initialized
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider: Object (name=http-basic-authentication) initialized
[Fri Jan 11 06:15:00 2013] [debug] Auth.Provider.HTTPBasicAuthentification: Got data (auth_name=, auth_type=)_

My system:
Debian Lenny with backports
PostgreSQL 8.4

@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Jan 11, 2013

Updated by dmikulski on 2013-01-11 12:58:05 +00:00

Hello,

sorry for this. I've tested your branch and also opened a new ticket regarding this.

https://dev.icinga.org/issues/3530

BR

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.