Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[dev.icinga.com #12527] Newly added group member tables in the IDO database are not updated #4549

Closed
icinga-migration opened this issue Aug 23, 2016 · 4 comments

Comments

Projects
None yet
1 participant
@icinga-migration
Copy link
Member

commented Aug 23, 2016

This issue has been migrated from Redmine: https://dev.icinga.com/issues/12527

Created by tontonitch on 2016-08-23 20:46:14 +00:00

Assignee: gbeutner
Status: Resolved (closed on 2016-08-24 09:39:28 +00:00)
Target Version: 2.5.2
Last Update: 2016-08-24 10:01:18 +00:00 (in Redmine)

Icinga Version: 2.5.1
Backport?: Not yet backported
Include in Changelog: 1

Hi,

I did an upgrade of Icinga2 from 2.4.10 to 2.5.1, and discovered that I was not able to create groups anymore: the new groups are not showed in IcingaWeb2.

After a rollback, I did the following to be sure of the issue:

  • copy of an existing group linux-servers to linux-servers2

    object HostGroup "linux-servers" {
    display_name = "Linux Servers"

    assign where host.vars.os == "linux"
    

    }
    object HostGroup "linux-servers2" {
    display_name = "Linux Servers2"

    assign where host.vars.os == "linux"
    

    }

==> the new group is well showed with the hosts.

  • upgrade of icinga2 (via yum, CentOS/RHEL)
  • again copy of an existing group linux-servers to linux-servers3

    object HostGroup "linux-servers3" {
    display_name = "Linux Servers3"

    assign where host.vars.os == "linux"
    

    }

==> the group doesn't appear in IcingaWeb2.

After some investigations, it seems that the groups are well created, but members seens to not be well linked: in the table Hostgroup_members for exemple, I don't see any record concerning my new groups.

Regards,
Yannick

Changesets

2016-08-24 09:35:12 +00:00 by gbeutner 04d86a7

Fix missing IDO updates for groups

fixes #12527

2016-08-24 09:50:29 +00:00 by gbeutner aa62a69

Fix missing IDO updates for groups

fixes #12527

2016-08-24 10:13:19 +00:00 by gbeutner bc88f81

Fix missing IDO updates for groups

fixes #12527

2016-08-24 10:22:09 +00:00 by gbeutner c981426

Fix missing IDO updates for groups

fixes #12527

2016-08-24 12:01:10 +00:00 by gbeutner b238df3

Fix missing IDO updates for groups

fixes #12527
@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Aug 24, 2016

Updated by gbeutner on 2016-08-24 08:43:35 +00:00

  • Status changed from New to Assigned
  • Assigned to set to mfriedrich
  • Target Version set to 2.5.2
@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Aug 24, 2016

Updated by gbeutner on 2016-08-24 09:39:28 +00:00

  • Status changed from Assigned to Resolved
  • Done % changed from 0 to 100

Applied in changeset 04d86a7.

@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Aug 24, 2016

Updated by mfriedrich on 2016-08-24 09:47:17 +00:00

  • Assigned to changed from mfriedrich to gbeutner
  • Priority changed from Normal to High
@icinga-migration

This comment has been minimized.

Copy link
Member Author

commented Aug 24, 2016

Updated by mfriedrich on 2016-08-24 10:01:18 +00:00

  • Subject changed from Groups (HostGroups, ServiceGroups, ContactGroups) created after 2.5.1 are not feeded with members to Newly added group member tables in the IDO database are not updated
  • Category changed from Configuration to DB IDO
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.