Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Attributes_Inspector] The container box sometimes not displayed correctly #25

Closed
sdavidg opened this issue Apr 1, 2014 · 7 comments

Comments

Projects
None yet
2 participants
@sdavidg
Copy link
Contributor

commented Apr 1, 2014

Attributes_Inspector version 0.6.3pre2 - 2013-11-11
FF 31.0a1 (2014-03-31) / FF 29_0b3

sin ttulo3
sin ttulo2

Infocatcher added a commit that referenced this issue Apr 1, 2014

Rorce repaint tooltip in Firefox 29+
(buggy at least in Windows 7 with classic theme)
(workaround for #25)
@Infocatcher

This comment has been minimized.

Copy link
Owner

commented Apr 1, 2014

Oh, I see. Looks like something was "optimized" in Firefox 29+. :(
Also all works fine for me with Windows 7 + Aero theme, but broken, if used classic theme.

I added some workarounds: still buggy reflects changes, but the data is at least visible.

@sdavidg

This comment has been minimized.

Copy link
Contributor Author

commented Apr 1, 2014

Great! Thanks for the quick fix

Infocatcher added a commit that referenced this issue Jun 15, 2014

Workaround to correctly work without inIFlasher
See https://bugzilla.mozilla.org/show_bug.cgi?id=1018324
Also see for alternative: https://bugzilla.mozilla.org/show_bug.cgi?id=368608 (but we already have style-based highlighting)
Note: workaround for #25 will not work anymore

Infocatcher added a commit that referenced this issue Jun 15, 2014

Force repaint tooltip in Firefox 33+
(still buggy in Windows 7 with classic theme)
(yet another workaround for #25)

Infocatcher added a commit that referenced this issue Jun 15, 2014

@Infocatcher

This comment has been minimized.

Copy link
Owner

commented Jun 15, 2014

I had to disable this workaround by default due to performance problems on latest Firefox 33.0a1.
Now should be changed manually:

-var _forceRepaintTooltip = false;
+var _forceRepaintTooltip = true;

Also old inIFlasher.repaintElement() doesn't work anymore and will be removed in Firefox 33 (32?):
https://bugzilla.mozilla.org/show_bug.cgi?id=1018324
So, I updated workaround: a bit more buggy now, but still better than nothing.

@Infocatcher

This comment has been minimized.

Copy link
Owner

commented Jun 15, 2014

@Infocatcher

This comment has been minimized.

Copy link
Owner

commented Nov 2, 2014

Our workaround doesn't work in Thunderbird 31.2.0, see http://custombuttons.sourceforge.net/forum/viewtopic.php?p=9807#p9807

sdavidg added a commit to sdavidg/Custom_Buttons that referenced this issue Dec 16, 2014

@sdavidg sdavidg referenced this issue Dec 16, 2014

Merged

repaintElement #30

Infocatcher added a commit that referenced this issue Dec 17, 2014

Merge pull request #30 from sdavidg/master
Trick to force repaint tooltip (#25)

Infocatcher added a commit that referenced this issue Dec 17, 2014

@Infocatcher

This comment has been minimized.

Copy link
Owner

commented Dec 18, 2014

Looks fixed now.
@sdavidg, thanks again.

@sdavidg

This comment has been minimized.

Copy link
Contributor Author

commented Dec 18, 2014

Thanks to you for this wonderful tool

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.