New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Updating of firmware for RealSense R200 Camera #429

Closed
fw-timku opened this Issue Feb 2, 2017 · 4 comments

Comments

Projects
None yet
5 participants
@fw-timku

fw-timku commented Feb 2, 2017

Required Info
Camera Model R200
Firmware Version
Operating System & Version 16.04 LTS
Kernel Version (Linux Only)

Hi all, I am currently using the Realsense R200 camera with firmware version of 1.0.71.10. I would like to know how do I go about updating the camera firmware to 1.0.72.10. What is the difference between the two firmware?

@zubair123khan

This comment has been minimized.

zubair123khan commented Mar 9, 2017

i am getting a warning :-

[ WARN] [1489075664.860111150]: /camera/driver - Detected unvalidated firmware:
- 2391012929's current camera firmware is 1.0.72.10, Validated camera firmware is 1.0.72.06

how to correct this.... now there is a problem if the camera firmware is up to date... strange !!

@dorodnic

This comment has been minimized.

Collaborator

dorodnic commented Mar 14, 2017

What tools are you using to update R200 firmware? Did you try to update using the latest versions of Digital Camera Manager?
In general, librealsense is agnostic to specific firmware versions and there is no special treatment of the different R200 firmware versions.

@molinadavid

This comment has been minimized.

molinadavid commented Mar 24, 2017

I have the same problem, I just updated the firmware on my camera using the official SDK and got the same message.

@mdhorn

This comment has been minimized.

Contributor

mdhorn commented Mar 24, 2017

@zubair123khan @molinadavid The WARNING you are seeing is from the realsense_camera ROS package, not librealsense.
It is only a Warning message denoting that the version of FW on hour camera is different from the version used to validated that release of realsense_camera ROS package.
This is used as an indicator to our QA team to update the version of FW used for validation.

In general, the warning can be ignored; it is a warning, not an error.

@dorodnic dorodnic closed this Apr 3, 2017

dorodnic added a commit that referenced this issue Aug 21, 2017

Merge pull request #429 from lramati/python
Make python bindings at least compile
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment