Permalink
Browse files

Rename CallInProgress.method to CallInProgress.http_method, tag v3

The method named "method" was giving me some grief, so I renamed it to
http_method, which is probably a more accurate name anyhow. As this is
a breaking API change, this is now v3.0.0 of the gem.

Also updated the test dependencies to Rails 3.2.12, since 3.2.8 is
pretty out of date.
  • Loading branch information...
1 parent 091b512 commit 6c8314d7587ba2e79865c13b42e63133f073093e @JMongol committed Feb 26, 2013
View
@@ -1,139 +1,140 @@
PATH
remote: .
specs:
- twilio-test-toolkit (1.0.1)
+ twilio-test-toolkit (3.0.0)
capybara
uuidtools
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.2.8)
- actionpack (= 3.2.8)
+ actionmailer (3.2.12)
+ actionpack (= 3.2.12)
mail (~> 2.4.4)
- actionpack (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
+ actionpack (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
- rack (~> 1.4.0)
+ rack (~> 1.4.5)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.1.3)
- activemodel (3.2.8)
- activesupport (= 3.2.8)
+ sprockets (~> 2.2.1)
+ activemodel (3.2.12)
+ activesupport (= 3.2.12)
builder (~> 3.0.0)
- activerecord (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
+ activerecord (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.8)
- activemodel (= 3.2.8)
- activesupport (= 3.2.8)
- activesupport (3.2.8)
+ activeresource (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ activesupport (3.2.12)
i18n (~> 0.6)
multi_json (~> 1.0)
- addressable (2.3.2)
arel (3.0.2)
- builder (3.0.3)
- capybara (1.1.2)
+ builder (3.0.4)
+ capybara (2.0.2)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
- xpath (~> 0.1.4)
- childprocess (0.3.5)
- ffi (~> 1.0, >= 1.0.6)
- diff-lcs (1.1.3)
+ xpath (~> 1.0.0)
+ childprocess (0.3.8)
+ ffi (~> 1.0, >= 1.0.11)
+ diff-lcs (1.2.1)
erubis (2.7.0)
- ffi (1.1.5)
+ ffi (1.4.0)
hike (1.2.1)
- i18n (0.6.1)
+ i18n (0.6.2)
journey (1.0.4)
- jquery-rails (2.1.2)
- railties (>= 3.1.0, < 5.0)
- thor (~> 0.14)
- json (1.7.5)
- libwebsocket (0.1.5)
- addressable
+ jquery-rails (2.2.1)
+ railties (>= 3.0, < 5.0)
+ thor (>= 0.14, < 2.0)
+ json (1.7.7)
mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.19)
- multi_json (1.3.6)
- nokogiri (1.5.5)
+ mime-types (1.21)
+ multi_json (1.6.1)
+ nokogiri (1.5.6)
polyglot (0.3.3)
- rack (1.4.1)
+ rack (1.4.5)
rack-cache (1.2)
rack (>= 0.4)
- rack-ssl (1.3.2)
+ rack-ssl (1.3.3)
rack
- rack-test (0.6.1)
+ rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.8)
- actionmailer (= 3.2.8)
- actionpack (= 3.2.8)
- activerecord (= 3.2.8)
- activeresource (= 3.2.8)
- activesupport (= 3.2.8)
+ rails (3.2.12)
+ actionmailer (= 3.2.12)
+ actionpack (= 3.2.12)
+ activerecord (= 3.2.12)
+ activeresource (= 3.2.12)
+ activesupport (= 3.2.12)
bundler (~> 1.0)
- railties (= 3.2.8)
- railties (3.2.8)
- actionpack (= 3.2.8)
- activesupport (= 3.2.8)
+ railties (= 3.2.12)
+ railties (3.2.12)
+ actionpack (= 3.2.12)
+ activesupport (= 3.2.12)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
- rake (0.9.2.2)
- rdoc (3.12)
+ rake (10.0.3)
+ rdoc (3.12.2)
json (~> 1.4)
- rspec (2.11.0)
- rspec-core (~> 2.11.0)
- rspec-expectations (~> 2.11.0)
- rspec-mocks (~> 2.11.0)
- rspec-core (2.11.1)
- rspec-expectations (2.11.2)
- diff-lcs (~> 1.1.3)
- rspec-mocks (2.11.2)
- rspec-rails (2.11.0)
+ rspec (2.13.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
+ rspec-core (2.13.0)
+ rspec-expectations (2.13.0)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-mocks (2.13.0)
+ rspec-rails (2.13.0)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
- rspec (~> 2.11.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
rubyzip (0.9.9)
- selenium-webdriver (2.25.0)
+ selenium-webdriver (2.30.0)
childprocess (>= 0.2.5)
- libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
rubyzip
- sprockets (2.1.3)
+ websocket (~> 1.0.4)
+ sprockets (2.2.2)
hike (~> 1.2)
+ multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- sqlite3 (1.3.6)
+ sqlite3 (1.3.7)
sqlite3-ruby (1.3.3)
sqlite3 (>= 1.3.3)
- thor (0.16.0)
+ thor (0.17.0)
tilt (1.3.3)
- treetop (1.4.10)
+ treetop (1.4.12)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.33)
+ tzinfo (0.3.35)
uuidtools (2.1.3)
- xpath (0.1.4)
+ websocket (1.0.7)
+ xpath (1.0.0)
nokogiri (~> 1.3)
PLATFORMS
ruby
DEPENDENCIES
jquery-rails
- rails (~> 3.2.8)
+ rails (~> 3.2.12)
rspec
rspec-rails
sqlite3
@@ -49,7 +49,7 @@ def is_machine
@is_machine
end
- def method
+ def http_method
@method
end
end
@@ -1,3 +1,3 @@
module TwilioTestToolkit
- VERSION = "2.0.0"
+ VERSION = "3.0.0"
end
@@ -21,7 +21,7 @@
end
it "should default the method to post" do
- @call.method.should == :post
+ @call.http_method.should == :post
end
it "should have the right properties" do
@@ -47,7 +47,7 @@
end
it "should be a get call" do
- @call.method.should == :get
+ @call.http_method.should == :get
end
end
end
@@ -23,7 +23,7 @@ Gem::Specification.new do |s|
s.add_dependency 'capybara'
s.add_dependency 'uuidtools'
- s.add_development_dependency "rails", "~> 3.2.8"
+ s.add_development_dependency "rails", "~> 3.2.12"
s.add_development_dependency "sqlite3"
s.add_development_dependency "sqlite3-ruby"
s.add_development_dependency "rspec"

0 comments on commit 6c8314d

Please sign in to comment.