Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tree: ac678937ce
Fetching contributors…

Cannot retrieve contributors at this time

159 lines (114 sloc) 4.79 kb

jnrowe-misc

This repository is for packages that don't naturally fit in to my other themed overlays.

If you find any problems with this overlay then please either file an issue or drop me an email.

Warning

This repository uses thin manifests, which requires a moderately recent version of portage to function correctly(2.1.10.18 or newer). Using older versions is not supported!

You can read the full documentation online, or in the doc directory if you prefer the reST source.

Contributors

I'd like to thank the following people who have contributed to this repository.

Patches

  • Leon Bird
  • Rachel Holmes
  • Matt Leighton
  • Bashshar Qaraja Maloof

Bug reports

  • Jake Archer
  • Daniel Brew
  • Dennis Bruce
  • Kristian Cole
  • Fabien Courtois
  • Ed Lyle
  • anna ruda
  • Erin Sandusky
  • Shi Tang
  • Jesper Tremblay
  • Matthew Turner
  • Jens Wulf

Ideas

  • Jamie Ashton
  • Robert Kincade
  • Scott Hunter
  • Ryan Lewis
  • Tony McKenzie
  • Patrick Sauvé

If I've forgotten to include your name I wholeheartedly apologise. Just drop me an email and I'll update the list!

Note

Some of these contributors pre-date the move to GitHub, but if you have access to the AST overlay you can see their contributions in its repository history.

Python multi-ABI support

Where applicable Python packages in this repository support multiple Python versions as specified in Gentoo Python Developers Guide. Unfortunately, there are various problems such as broken dependency specification that can't be worked around using the prescribed method.

If you find any dependency problems with the Python packages in this overlay please check the ebuild and try to resolve the problem yourself before reporting bugs. There is very little that can be done to fix this without breaking compatibility with upstream, so bugs relating to multiple ABI support will likely be closed as CANTFIX.

Hopefully upstream will fix or acknowledge the breakages soon, and then this can be resolved correctly.

oilman integration

If you use oilman to manage your repositories you can call:

# oilman --add-repository jnrowe::misc

Or, if you'd rather use the rsync mirror:

# oilman --method=rsync --add-repository jnrowe::misc

To sync the repository:

# oilman --sync jnrowe::misc  # Sync this repository only
# oilman --sync all  # or sync all repositories

layman integration

If you use layman to sync your repositories you can easily add this repository to the supported list.

If you're using layman v1.2.4 or newer, then the support/layman2.xml should be added to the overlays section of /etc/layman/layman.conf, for example:

overlays  : http://www.gentoo.org/proj/en/overlays/repositories.xml
            https://github.com/JNRowe/jnrowe-misc/raw/master/support/layman2.xml

If you're using layman v1.2.3 or earlier, then support/layman.xml should be added to the overlays section of /etc/layman/layman.conf, for example:

overlays  : http://www.gentoo.org/proj/en/overlays/layman-global.txt
            https://github.com/JNRowe/jnrowe-misc/raw/master/support/layman.xml

Then you can add the overlay using layman:

# layman -a jnrowe-misc

Note

You may need to run layman --fetch or perform a sync operation before this command will work.

To sync the repository you can use layman directly, either syncing just this overlay or all your overlays at once:

# layman -s jnrowe-misc  # Sync just jnrowe-misc
# layman -S  # or sync all layman managed overlays

Or if you're an eix user you can use eix-sync to update the repositories and the eix database at the same time, first tell eix-sync to update the repository:

# echo "jnrowe-misc" >>/etc/eix-sync.conf  # Sync just jnrowe-misc
# echo "*" >>/etc/eix-sync.conf  # or sync all layman managed overlays

Finally, call eix-sync to update the specified repositories and eix package database.

cupage integration

cupage is used to keep packages in sync with their releases, see support/cupage.conf. cupage v0.5.5, or above, is required if you wish to make use of this functionality.

Jump to Line
Something went wrong with that request. Please try again.