Permalink
Browse files

move to 2.4.0 + testing doc

  • Loading branch information...
1 parent b36264e commit 1faacabac95e1b329ec85d0c755948fb827db707 @JPMoresmau committed Dec 14, 2012
@@ -74,28 +74,28 @@ available at http://www.eclipse.org/legal/epl-v10.html.
id="net.sf.eclipsefp.haskell"
download-size="0"
install-size="0"
- version="2.3.2"
+ version="2.4.0"
unpack="false"/>
<plugin
id="net.sf.eclipsefp.haskell.core"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
id="net.sf.eclipsefp.haskell.doc.user"
download-size="0"
install-size="0"
- version="2.3.2"
+ version="2.4.0"
unpack="false"/>
<plugin
id="net.sf.eclipsefp.haskell.ui"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
@@ -116,14 +116,14 @@ available at http://www.eclipse.org/legal/epl-v10.html.
id="net.sf.eclipsefp.haskell.debug.ui"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
id="net.sf.eclipsefp.haskell.debug.core"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
@@ -137,14 +137,14 @@ available at http://www.eclipse.org/legal/epl-v10.html.
id="net.sf.eclipsefp.haskell.util"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
id="net.sf.eclipsefp.haskell.browser"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
@@ -158,7 +158,7 @@ available at http://www.eclipse.org/legal/epl-v10.html.
id="net.sf.eclipsefp.haskell.buildwrapper"
download-size="0"
install-size="0"
- version="2.3.3"
+ version="2.4.0"
unpack="false"/>
<plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.browser; singleton:=true
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Localization: plugin
Bundle-Activator: net.sf.eclipsefp.haskell.browser.BrowserPlugin
Require-Bundle: org.eclipse.ui;bundle-version="3.2.0",
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.buildwrapper;singleton:=true
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Activator: net.sf.eclipsefp.haskell.buildwrapper.BuildWrapperPlugin
Bundle-Vendor: %bundleVendor
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Plug-in for testing Haskell Core
Bundle-SymbolicName: net.sf.eclipsefp.haskell.core.test
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Vendor: eclipsefp.sourceforge.net
Require-Bundle: org.easymock;bundle-version="[2.2.0,3.0.0)",
org.junit4,
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.core;singleton:=true
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Activator: net.sf.eclipsefp.haskell.core.HaskellCorePlugin
Bundle-Vendor: %bundleVendor
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.debug.core;singleton:=true
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Activator: net.sf.eclipsefp.haskell.debug.core.internal.HaskellDebugCore
Bundle-Vendor: %bundleVendor
Require-Bundle: org.eclipse.core.runtime,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.debug.ui;singleton:=true
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Activator: net.sf.eclipsefp.haskell.debug.ui.internal.HaskellDebugUI
Bundle-Vendor: %bundleVendor
Require-Bundle: net.sf.eclipsefp.haskell.ghccompiler,
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.doc.user;singleton:=true
-Bundle-Version: 2.3.2
+Bundle-Version: 2.4.0
Bundle-Vendor: %bundleVendor
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
@@ -1,19 +1,29 @@
-<html>
-<head>
-<link rel="stylesheet" href="../../../PRODUCT_PLUGIN/book.css" type="text/css">
-</head>
-
-<body>
-
-<h1>Testing</h1>
-
-<p>The plug-in can execute Test-framework tests directly from the developer environment.
-For documentation about how to use Test-framework, please refer to the
-<a href="http://batterseapower.github.com/test-framework/">official documentation</a>.</p>
-
-<p>To start a test right-click the project root, and select <b>Run As > Test-framework test</b>.
-The list of available test suites is shown, select the one you would like to run. Once it
-is finished, the results are shown in a <i>JUnit</i> view.</p>
-
-</body>
-</html>
+<html>
+<head>
+<link rel="stylesheet" href="../../../PRODUCT_PLUGIN/book.css" type="text/css">
+</head>
+
+<body>
+
+<h1>Testing</h1>
+
+<p>The recommended Haskell framework for tests is HTF.
+For documentation about how to use HTF, please refer to the
+<a href="http://hackage.haskell.org/package/HTF">official documentation</a>.</p>
+
+<p>To start a test right-click the project root, and select <b>Run As > HTF test</b>.
+The list of available test suites is shown, select the one you would like to run. The results are shown as they progress in the <i>Haskell Test Results</i> view.</p>
+
+<p>There is also a HTF wizard in the Cabal editor. In the test suites section, you can create a new HTF test suite by indicating the source folder and the modules to test.
+A HTF module is created for each module tested, and a main module importing all of these is also created. A video of HTF integration can be found one <a href="http://www.youtube.com/watch?v=VP9PgGFZYxM">YouTube</a></p>
+
+<p>The plug-in can also execute Test-framework tests directly from the developer environment.
+For documentation about how to use Test-framework, please refer to the
+<a href="http://batterseapower.github.com/test-framework/">official documentation</a>.</p>
+
+<p>To start a test right-click the project root, and select <b>Run As > Test-framework test</b>.
+The list of available test suites is shown, select the one you would like to run. Once it
+is finished, the results are shown in the <i>Haskell Test Results</i> view.</p>
+
+</body>
+</html>
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Haskell UI Test Plug-in
Bundle-SymbolicName: net.sf.eclipsefp.haskell.ui.test
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Vendor: eclipsefp.sourceforge.net
Require-Bundle: org.junit4,
org.easymock;bundle-version="[2.2.0,3.0.0)",
@@ -1,7 +1,7 @@
Manifest-Version: 1.0
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.ui;singleton:=true
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Activator: net.sf.eclipsefp.haskell.ui.HaskellUIPlugin
Bundle-Vendor: %bundleVendor
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell.util
-Bundle-Version: 2.3.3
+Bundle-Version: 2.4.0
Bundle-Activator: net.sf.eclipsefp.haskell.util.Activator
Require-Bundle: org.eclipse.core.runtime,
org.eclipse.core.resources,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %bundleName
Bundle-SymbolicName: net.sf.eclipsefp.haskell;singleton:=true
-Bundle-Version: 2.3.2
+Bundle-Version: 2.4.0
Bundle-Vendor: %bundleVendor
Bundle-Localization: plugin
Require-Bundle: org.eclipse.ui.cheatsheets;bundle-version="[3.2.0,4.0.0)",

0 comments on commit 1faacab

Please sign in to comment.