Skip to content
This repository
Browse code

Merge pull request #50 from Oblosys/master

Ignore bin directory
  • Loading branch information...
commit b2d38660314083f6357e646876f6c4713f0c9ca9 2 parents 33542d1 + 01834dc
JP Moresmau authored July 04, 2012
342  net.sf.eclipsefp.haskell-feature/feature.xml
... ...
@@ -1,179 +1,171 @@
1  
-<?xml version="1.0" encoding="UTF-8"?>
2  
-<feature
3  
-      id="net.sf.eclipsefp.haskell"
4  
-      label="%bundleName"
5  
-      version="2.3.1"
6  
-      provider-name="%bundleVendor">
7  
-
8  
-   <description>
9  
-      Adds tools for the Haskell programming language to the Eclipse IDE.
10  
-   </description>
11  
-
12  
-   <copyright>
13  
-      Copyright (c) 2003-2011 by the EclipseFP contributors
14  
-Contains SQLite, Public Domain
  1
+<?xml version="1.0" encoding="UTF-8"?>
  2
+<feature
  3
+      id="net.sf.eclipsefp.haskell"
  4
+      label="%bundleName"
  5
+      version="2.3.1"
  6
+      provider-name="%bundleVendor">
  7
+
  8
+   <description>
  9
+      Adds tools for the Haskell programming language to the Eclipse IDE.
  10
+   </description>
  11
+
  12
+   <copyright>
  13
+      Copyright (c) 2003-2011 by the EclipseFP contributors
  14
+Contains SQLite, Public Domain
15 15
 Contains sqlite-jdbc from xerial.org (http://www.xerial.org/trac/Xerial/wiki/SQLiteJDBC) (http://www.apache.org/licenses/LICENSE-2.0)
16  
-Contains SnakeYAML (http://code.google.com/p/snakeyaml/) (http://www.apache.org/licenses/LICENSE-2.0)
17  
-   </copyright>
18  
-
19  
-   <license url="http://www.eclipse.org/legal/epl-v10.html">
  16
+Contains SnakeYAML (http://code.google.com/p/snakeyaml/) (http://www.apache.org/licenses/LICENSE-2.0)
  17
+   </copyright>
  18
+
  19
+   <license url="http://www.eclipse.org/legal/epl-v10.html">
20 20
       This content is made available by the project eclipsefp.sourceforge.net
21 21
 under the terms of the Eclipse Public License Version 1.0 (EPL).
22 22
 A copy of the EPL is provided with this content and is also 
23  
-available at http://www.eclipse.org/legal/epl-v10.html.
24  
-   </license>
25  
-
26  
-   <requires>
27  
-      <import plugin="org.eclipse.ui.cheatsheets" version="3.2.0" match="compatible"/>
28  
-      <import plugin="org.eclipse.core.expressions" version="3.2.0" match="compatible"/>
29  
-      <import plugin="org.eclipse.core.runtime" version="3.2.0" match="compatible"/>
30  
-      <import plugin="org.eclipse.debug.core" version="3.2.0" match="compatible"/>
31  
-      <import plugin="org.eclipse.ui" version="3.5.0" match="greaterOrEqual"/>
32  
-      <import plugin="org.eclipse.text" version="3.5.0" match="greaterOrEqual"/>
33  
-      <import plugin="org.eclipse.ui.editors" version="3.5.0" match="greaterOrEqual"/>
34  
-      <import plugin="org.eclipse.ui.ide" version="3.5.2" match="greaterOrEqual"/>
35  
-      <import plugin="org.eclipse.jface.text" version="3.2.0" match="compatible"/>
36  
-      <import plugin="org.eclipse.ltk.core.refactoring"/>
37  
-      <import plugin="org.eclipse.ltk.ui.refactoring"/>
38  
-      <import plugin="org.eclipse.ui" version="3.2.0" match="compatible"/>
39  
-      <import plugin="org.eclipse.ui.console" version="3.1.0" match="compatible"/>
40  
-      <import plugin="org.eclipse.ui.ide" version="3.2.0" match="compatible"/>
41  
-      <import plugin="org.eclipse.ui.navigator"/>
42  
-      <import plugin="org.eclipse.ui.views" version="3.2.0" match="compatible"/>
43  
-      <import plugin="org.eclipse.ui.workbench.texteditor" version="3.2.0" match="compatible"/>
44  
-      <import plugin="org.eclipse.debug.ui" version="3.2.0" match="compatible"/>
45  
-      <import plugin="org.eclipse.ui.forms"/>
46  
-      <import plugin="org.eclipse.core.variables" version="3.2.200" match="greaterOrEqual"/>
47  
-      <import plugin="org.apache.ant"/>
48  
-      <import plugin="org.eclipse.core.filesystem"/>
49  
-      <import plugin="org.eclipse.core.resources" version="3.2.0" match="compatible"/>
50  
-      <import plugin="org.eclipse.jface.text" version="3.5.0" match="greaterOrEqual"/>
51  
-      <import plugin="org.eclipse.ui.workbench.texteditor" version="3.5.0" match="greaterOrEqual"/>
52  
-      <import plugin="org.eclipse.jface.text" version="3.5.1" match="greaterOrEqual"/>
53  
-      <import plugin="org.eclipse.ui.console" version="3.2.0" match="greaterOrEqual"/>
54  
-      <import plugin="org.eclipse.jface.text" version="3.2.0" match="greaterOrEqual"/>
55  
-      <import plugin="org.eclipse.osgi"/>
56  
-      <import plugin="org.eclipse.core.net"/>
57  
-      <import plugin="org.eclipse.ui" version="3.2.0" match="greaterOrEqual"/>
58  
-      <import plugin="org.eclipse.core.runtime" version="3.2.0" match="greaterOrEqual"/>
59  
-      <import plugin="org.eclipse.core.commands"/>
60  
-      <import plugin="org.eclipse.jface"/>
61  
-      <import plugin="org.eclipse.swt"/>
62  
-      <import plugin="org.eclipse.core.resources" version="3.5.2" match="greaterOrEqual"/>
63  
-      <import plugin="org.eclipse.jface.text" version="3.5.2" match="greaterOrEqual"/>
64  
-      <import plugin="net.sf.eclipsefp.haskell.ui"/>
65  
-      <import plugin="net.sf.eclipsefp.haskell.haddock"/>
66  
-      <import plugin="net.sf.eclipsefp.haskell.core"/>
67  
-      <import plugin="net.sf.eclipsefp.haskell.util"/>
68  
-      <import plugin="net.sf.eclipsefp.haskell.debug.ui"/>
69  
-      <import plugin="net.sf.eclipsefp.haskell.debug.core"/>
70  
-      <import plugin="net.sf.eclipsefp.haskell.ghccompiler"/>
71  
-      <import plugin="net.sf.eclipsefp.haskell.compat"/>
72  
-   </requires>
73  
-
74  
-   <plugin
75  
-         id="net.sf.eclipsefp.haskell"
76  
-         download-size="0"
77  
-         install-size="0"
78  
-         version="2.2.4"
79  
-         unpack="false"/>
80  
-
81  
-   <plugin
82  
-         id="net.sf.eclipsefp.haskell.core"
83  
-         download-size="0"
84  
-         install-size="0"
85  
-         version="2.3.1"
86  
-         unpack="false"/>
87  
-
88  
-   <plugin
89  
-         id="net.sf.eclipsefp.haskell.doc.user"
90  
-         download-size="0"
91  
-         install-size="0"
92  
-         version="2.2.4"
93  
-         unpack="false"/>
94  
-
95  
-   <plugin
96  
-         id="net.sf.eclipsefp.haskell.ui"
97  
-         download-size="0"
98  
-         install-size="0"
99  
-         version="2.3.1"
100  
-         unpack="false"/>
101  
-
102  
-   <plugin
103  
-         id="net.sf.eclipsefp.haskell.hugs"
104  
-         download-size="0"
105  
-         install-size="0"
106  
-         version="2.3.1"
107  
-         unpack="false"/>
108  
-
109  
-   <plugin
110  
-         id="net.sf.eclipsefp.haskell.ghccompiler"
111  
-         download-size="0"
112  
-         install-size="0"
113  
-         version="2.2.4"
114  
-         unpack="false"/>
115  
-
116  
-   <plugin
117  
-         id="net.sf.eclipsefp.haskell.debug.ui"
118  
-         download-size="0"
119  
-         install-size="0"
120  
-         version="2.3.1"
121  
-         unpack="false"/>
122  
-
123  
-   <plugin
124  
-         id="net.sf.eclipsefp.haskell.debug.core"
125  
-         download-size="0"
126  
-         install-size="0"
127  
-         version="2.3.1"
128  
-         unpack="false"/>
129  
-
130  
-   <plugin
131  
-         id="net.sf.eclipsefp.haskell.compat"
132  
-         download-size="0"
133  
-         install-size="0"
134  
-         version="2.2.4"
135  
-         unpack="false"/>
136  
-
137  
-   <plugin
138  
-         id="net.sf.eclipsefp.haskell.util"
139  
-         download-size="0"
140  
-         install-size="0"
141  
-         version="2.3.1"
142  
-         unpack="false"/>
143  
-
144  
-   <plugin
145  
-         id="net.sf.eclipsefp.haskell.browser"
146  
-         download-size="0"
147  
-         install-size="0"
148  
-         version="2.3.0"
149  
-         unpack="false"/>
150  
-
151  
-   <plugin
152  
-         id="net.sf.eclipsefp.haskell.hlint"
153  
-         download-size="0"
154  
-         install-size="0"
155  
-         version="2.3.1"
156  
-         unpack="false"/>
157  
-
158  
-   <plugin
159  
-         id="net.sf.eclipsefp.haskell.profiler"
160  
-         download-size="0"
161  
-         install-size="0"
162  
-         version="2.3.0"
163  
-         unpack="false"/>
164  
-
165  
-   <plugin
166  
-         id="net.sf.eclipsefp.haskell.buildwrapper"
167  
-         download-size="0"
168  
-         install-size="0"
169  
-         version="2.3.1"
170  
-         unpack="false"/>
171  
-
172  
-   <plugin
173  
-         id="net.sf.eclipsefp.haskell.style"
174  
-         download-size="0"
175  
-         install-size="0"
176  
-         version="2.3.1"
177  
-         unpack="false"/>
178  
-
179  
-</feature>
  23
+available at http://www.eclipse.org/legal/epl-v10.html.
  24
+   </license>
  25
+
  26
+   <requires>
  27
+      <import plugin="org.eclipse.ui.cheatsheets" version="3.2.0" match="compatible"/>
  28
+      <import plugin="net.sf.eclipsefp.haskell.ui"/>
  29
+      <import plugin="org.eclipse.core.expressions" version="3.2.0" match="compatible"/>
  30
+      <import plugin="org.eclipse.core.runtime" version="3.2.0" match="compatible"/>
  31
+      <import plugin="org.eclipse.debug.core" version="3.2.0" match="compatible"/>
  32
+      <import plugin="org.eclipse.ui" version="3.5.0" match="greaterOrEqual"/>
  33
+      <import plugin="org.eclipse.text" version="3.5.0" match="greaterOrEqual"/>
  34
+      <import plugin="org.eclipse.ui.editors" version="3.5.0" match="greaterOrEqual"/>
  35
+      <import plugin="org.eclipse.ui.ide" version="3.5.2" match="greaterOrEqual"/>
  36
+      <import plugin="org.eclipse.jface.text" version="3.2.0" match="compatible"/>
  37
+      <import plugin="org.eclipse.ltk.core.refactoring"/>
  38
+      <import plugin="org.eclipse.ltk.ui.refactoring"/>
  39
+      <import plugin="org.eclipse.ui" version="3.2.0" match="compatible"/>
  40
+      <import plugin="org.eclipse.ui.console" version="3.1.0" match="compatible"/>
  41
+      <import plugin="org.eclipse.ui.ide" version="3.2.0" match="compatible"/>
  42
+      <import plugin="org.eclipse.ui.navigator"/>
  43
+      <import plugin="org.eclipse.ui.views" version="3.2.0" match="compatible"/>
  44
+      <import plugin="org.eclipse.ui.workbench.texteditor" version="3.2.0" match="compatible"/>
  45
+      <import plugin="org.eclipse.debug.ui" version="3.2.0" match="compatible"/>
  46
+      <import plugin="org.eclipse.ui.forms"/>
  47
+      <import plugin="org.eclipse.core.variables" version="3.2.200" match="greaterOrEqual"/>
  48
+      <import plugin="org.apache.ant"/>
  49
+      <import plugin="org.eclipse.core.filesystem"/>
  50
+      <import plugin="net.sf.eclipsefp.haskell.core"/>
  51
+      <import plugin="net.sf.eclipsefp.haskell.util"/>
  52
+      <import plugin="net.sf.eclipsefp.haskell.debug.ui"/>
  53
+      <import plugin="org.eclipse.core.resources" version="3.2.0" match="compatible"/>
  54
+      <import plugin="net.sf.eclipsefp.haskell.debug.core"/>
  55
+      <import plugin="org.eclipse.jface.text" version="3.5.0" match="greaterOrEqual"/>
  56
+      <import plugin="net.sf.eclipsefp.haskell.ghccompiler"/>
  57
+      <import plugin="org.eclipse.ui.workbench.texteditor" version="3.5.0" match="greaterOrEqual"/>
  58
+      <import plugin="org.eclipse.jface.text" version="3.5.1" match="greaterOrEqual"/>
  59
+      <import plugin="net.sf.eclipsefp.haskell.compat"/>
  60
+      <import plugin="org.eclipse.jface.text" version="3.2.0" match="greaterOrEqual"/>
  61
+      <import plugin="org.eclipse.osgi"/>
  62
+      <import plugin="org.eclipse.core.net"/>
  63
+      <import plugin="org.eclipse.ui" version="3.2.0" match="greaterOrEqual"/>
  64
+      <import plugin="org.eclipse.core.runtime" version="3.2.0" match="greaterOrEqual"/>
  65
+      <import plugin="org.eclipse.core.resources" version="3.5.2" match="greaterOrEqual"/>
  66
+      <import plugin="org.eclipse.jface.text" version="3.5.2" match="greaterOrEqual"/>
  67
+      <import plugin="org.eclipse.swt"/>
  68
+      <import plugin="org.eclipse.jface"/>
  69
+      <import plugin="org.eclipse.search"/>
  70
+      <import plugin="org.eclipse.ui.workbench"/>
  71
+   </requires>
  72
+
  73
+   <plugin
  74
+         id="net.sf.eclipsefp.haskell"
  75
+         download-size="0"
  76
+         install-size="0"
  77
+         version="2.2.4"
  78
+         unpack="false"/>
  79
+
  80
+   <plugin
  81
+         id="net.sf.eclipsefp.haskell.core"
  82
+         download-size="0"
  83
+         install-size="0"
  84
+         version="2.3.1"
  85
+         unpack="false"/>
  86
+
  87
+   <plugin
  88
+         id="net.sf.eclipsefp.haskell.doc.user"
  89
+         download-size="0"
  90
+         install-size="0"
  91
+         version="2.2.4"
  92
+         unpack="false"/>
  93
+
  94
+   <plugin
  95
+         id="net.sf.eclipsefp.haskell.ui"
  96
+         download-size="0"
  97
+         install-size="0"
  98
+         version="2.3.1"
  99
+         unpack="false"/>
  100
+
  101
+   <plugin
  102
+         id="net.sf.eclipsefp.haskell.hugs"
  103
+         download-size="0"
  104
+         install-size="0"
  105
+         version="2.3.1"
  106
+         unpack="false"/>
  107
+
  108
+   <plugin
  109
+         id="net.sf.eclipsefp.haskell.ghccompiler"
  110
+         download-size="0"
  111
+         install-size="0"
  112
+         version="2.2.4"
  113
+         unpack="false"/>
  114
+
  115
+   <plugin
  116
+         id="net.sf.eclipsefp.haskell.debug.ui"
  117
+         download-size="0"
  118
+         install-size="0"
  119
+         version="2.3.1"
  120
+         unpack="false"/>
  121
+
  122
+   <plugin
  123
+         id="net.sf.eclipsefp.haskell.debug.core"
  124
+         download-size="0"
  125
+         install-size="0"
  126
+         version="2.3.1"
  127
+         unpack="false"/>
  128
+
  129
+   <plugin
  130
+         id="net.sf.eclipsefp.haskell.compat"
  131
+         download-size="0"
  132
+         install-size="0"
  133
+         version="2.2.4"
  134
+         unpack="false"/>
  135
+
  136
+   <plugin
  137
+         id="net.sf.eclipsefp.haskell.util"
  138
+         download-size="0"
  139
+         install-size="0"
  140
+         version="2.3.1"
  141
+         unpack="false"/>
  142
+
  143
+   <plugin
  144
+         id="net.sf.eclipsefp.haskell.browser"
  145
+         download-size="0"
  146
+         install-size="0"
  147
+         version="2.3.0"
  148
+         unpack="false"/>
  149
+
  150
+   <plugin
  151
+         id="net.sf.eclipsefp.haskell.hlint"
  152
+         download-size="0"
  153
+         install-size="0"
  154
+         version="2.3.1"
  155
+         unpack="false"/>
  156
+
  157
+   <plugin
  158
+         id="net.sf.eclipsefp.haskell.buildwrapper"
  159
+         download-size="0"
  160
+         install-size="0"
  161
+         version="2.3.1"
  162
+         unpack="false"/>
  163
+
  164
+   <plugin
  165
+         id="net.sf.eclipsefp.haskell.style"
  166
+         download-size="0"
  167
+         install-size="0"
  168
+         version="2.3.1"
  169
+         unpack="false"/>
  170
+
  171
+</feature>
1  net.sf.eclipsefp.haskell.style/.gitignore
... ...
@@ -1 +1,2 @@
1 1
 /.settings
  2
+/bin/
3  net.sf.eclipsefp.haskell/META-INF/MANIFEST.MF
@@ -6,7 +6,6 @@ Bundle-Version: 2.2.4
6 6
 Bundle-Vendor: %bundleVendor
7 7
 Bundle-Localization: plugin
8 8
 Require-Bundle: org.eclipse.ui.cheatsheets;bundle-version="[3.2.0,4.0.0)",
9  
- net.sf.eclipsefp.haskell.ui,
10  
- net.sf.eclipsefp.haskell.haddock
  9
+ net.sf.eclipsefp.haskell.ui
11 10
 Bundle-ActivationPolicy: lazy
12 11
 Bundle-RequiredExecutionEnvironment: JavaSE-1.6

0 notes on commit b2d3866

Please sign in to comment.
Something went wrong with that request. Please try again.