Skip to content
Browse files

hslogger_constraints_101220

Update the constraints for hslogger: >= 1.0 is required if no flags are
specified, >= 1.1 is required if cabal_1_8 flag is set.
  • Loading branch information...
1 parent adc367e commit 2cc186a1d3e0b558067f943c29e786ec8498206f Scott Michel committed Dec 20, 2010
Showing with 13 additions and 12 deletions.
  1. +13 −12 scion.cabal
View
25 scion.cabal
@@ -46,6 +46,7 @@ library
containers >= 0.2 && < 0.4,
directory == 1.0.*,
filepath == 1.1.*,
+ hslogger >= 1.0,
ghc >= 6.10 && < 6.13,
ghc-paths == 0.1.*,
ghc-syb,
@@ -62,13 +63,12 @@ library
if flag(cabal_1_8)
build-depends:
- Cabal >= 1.8,
- hslogger == 1.1.*
+ Cabal >= 1.8,
+ hslogger >= 1.1
cpp-options: -DCABAL_VERSION=108
else
build-depends:
- Cabal == 1.6.*,
- hslogger == 1.0.*
+ Cabal == 1.6.*
cpp-options: -DCABAL_VERSION=106
hs-source-dirs: lib
@@ -127,6 +127,7 @@ executable scion-server
ghc-paths == 0.1.*,
ghc-syb,
ghc-syb-utils,
+ hslogger >= 1.0,
AttoJson >= 0.5.8,
multiset >= 0.1 && < 0.3,
time == 1.1.*,
@@ -138,13 +139,12 @@ executable scion-server
if flag(cabal_1_8)
build-depends:
- Cabal >= 1.8,
- hslogger == 1.1.*
+ Cabal >= 1.8,
+ hslogger >= 1.1
cpp-options: -DCABAL_VERSION=108
else
build-depends:
- Cabal == 1.6.*,
- hslogger == 1.0.*
+ Cabal == 1.6.*
cpp-options: -DCABAL_VERSION=106
if flag(server)
@@ -191,6 +191,7 @@ executable scion-test
ghc-paths == 0.1.*,
ghc-syb,
ghc-syb-utils,
+ hslogger >= 1.0,
AttoJson >= 0.5.8,
multiset >= 0.1 && < 0.3,
time == 1.1.*,
@@ -205,12 +206,12 @@ executable scion-test
if flag(cabal_1_8)
build-depends:
- Cabal >= 1.8,
- hslogger == 1.1.*
+ Cabal >= 1.8,
+ hslogger >= 1.1
cpp-options: -DCABAL_VERSION=108
else
- build-depends: Cabal == 1.6.*,
- hslogger == 1.0.*
+ build-depends:
+ Cabal == 1.6.*
cpp-options: -DCABAL_VERSION=106
hs-source-dirs: lib

0 comments on commit 2cc186a

Please sign in to comment.
Something went wrong with that request. Please try again.