Permalink
Browse files

Created a rails app and added status updates

  • Loading branch information...
0 parents commit d1c1945f70650200771dba06a5c895560f06570f @JacobKorn committed Oct 4, 2012
Showing with 1,547 additions and 0 deletions.
  1. +15 −0 .gitignore
  2. +38 −0 Gemfile
  3. +111 −0 Gemfile.lock
  4. +261 −0 README.rdoc
  5. +7 −0 Rakefile
  6. BIN app/assets/images/rails.png
  7. +15 −0 app/assets/javascripts/application.js
  8. +3 −0 app/assets/javascripts/statuses.js.coffee
  9. +13 −0 app/assets/stylesheets/application.css
  10. +69 −0 app/assets/stylesheets/scaffolds.css.scss
  11. +3 −0 app/assets/stylesheets/statuses.css.scss
  12. +3 −0 app/controllers/application_controller.rb
  13. +83 −0 app/controllers/statuses_controller.rb
  14. +2 −0 app/helpers/application_helper.rb
  15. +2 −0 app/helpers/statuses_helper.rb
  16. 0 app/mailers/.gitkeep
  17. 0 app/models/.gitkeep
  18. +3 −0 app/models/status.rb
  19. +14 −0 app/views/layouts/application.html.erb
  20. +25 −0 app/views/statuses/_form.html.erb
  21. +6 −0 app/views/statuses/edit.html.erb
  22. +25 −0 app/views/statuses/index.html.erb
  23. +5 −0 app/views/statuses/new.html.erb
  24. +15 −0 app/views/statuses/show.html.erb
  25. +4 −0 config.ru
  26. +62 −0 config/application.rb
  27. +6 −0 config/boot.rb
  28. +25 −0 config/database.yml
  29. +5 −0 config/environment.rb
  30. +37 −0 config/environments/development.rb
  31. +67 −0 config/environments/production.rb
  32. +37 −0 config/environments/test.rb
  33. +7 −0 config/initializers/backtrace_silencers.rb
  34. +15 −0 config/initializers/inflections.rb
  35. +5 −0 config/initializers/mime_types.rb
  36. +7 −0 config/initializers/secret_token.rb
  37. +8 −0 config/initializers/session_store.rb
  38. +14 −0 config/initializers/wrap_parameters.rb
  39. +5 −0 config/locales/en.yml
  40. +60 −0 config/routes.rb
  41. +10 −0 db/migrate/20121004104428_create_statuses.rb
  42. +23 −0 db/schema.rb
  43. +7 −0 db/seeds.rb
  44. +2 −0 doc/README_FOR_APP
  45. 0 lib/assets/.gitkeep
  46. 0 lib/tasks/.gitkeep
  47. 0 log/.gitkeep
  48. +26 −0 public/404.html
  49. +26 −0 public/422.html
  50. +25 −0 public/500.html
  51. 0 public/favicon.ico
  52. +241 −0 public/index.html
  53. +5 −0 public/robots.txt
  54. +6 −0 script/rails
  55. 0 test/fixtures/.gitkeep
  56. +9 −0 test/fixtures/statuses.yml
  57. 0 test/functional/.gitkeep
  58. +49 −0 test/functional/statuses_controller_test.rb
  59. 0 test/integration/.gitkeep
  60. +12 −0 test/performance/browsing_test.rb
  61. +13 −0 test/test_helper.rb
  62. 0 test/unit/.gitkeep
  63. +4 −0 test/unit/helpers/statuses_helper_test.rb
  64. +7 −0 test/unit/status_test.rb
  65. 0 vendor/assets/javascripts/.gitkeep
  66. 0 vendor/assets/stylesheets/.gitkeep
  67. 0 vendor/plugins/.gitkeep
@@ -0,0 +1,15 @@
+# See http://help.github.com/ignore-files/ for more about ignoring files.
+#
+# If you find yourself ignoring temporary files generated by your text editor
+# or operating system, you probably want to add a global ignore instead:
+# git config --global core.excludesfile ~/.gitignore_global
+
+# Ignore bundler config
+/.bundle
+
+# Ignore the default SQLite database.
+/db/*.sqlite3
+
+# Ignore all logfiles and tempfiles.
+/log/*.log
+/tmp
38 Gemfile
@@ -0,0 +1,38 @@
+source 'https://rubygems.org'
+
+gem 'rails', '3.2.8'
+
+# Bundle edge Rails instead:
+# gem 'rails', :git => 'git://github.com/rails/rails.git'
+
+gem 'sqlite3'
+
+
+# Gems used only for assets and not required
+# in production environments by default.
+group :assets do
+ gem 'sass-rails', '~> 3.2.3'
+ gem 'coffee-rails', '~> 3.2.1'
+
+ # See https://github.com/sstephenson/execjs#readme for more supported runtimes
+ # gem 'therubyracer', :platforms => :ruby
+
+ gem 'uglifier', '>= 1.0.3'
+end
+
+gem 'jquery-rails'
+
+# To use ActiveModel has_secure_password
+# gem 'bcrypt-ruby', '~> 3.0.0'
+
+# To use Jbuilder templates for JSON
+# gem 'jbuilder'
+
+# Use unicorn as the app server
+# gem 'unicorn'
+
+# Deploy with Capistrano
+# gem 'capistrano'
+
+# To use debugger
+# gem 'debugger'
@@ -0,0 +1,111 @@
+GEM
+ remote: https://rubygems.org/
+ specs:
+ actionmailer (3.2.8)
+ actionpack (= 3.2.8)
+ mail (~> 2.4.4)
+ actionpack (3.2.8)
+ activemodel (= 3.2.8)
+ activesupport (= 3.2.8)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ journey (~> 1.0.4)
+ rack (~> 1.4.0)
+ rack-cache (~> 1.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.1.3)
+ activemodel (3.2.8)
+ activesupport (= 3.2.8)
+ builder (~> 3.0.0)
+ activerecord (3.2.8)
+ activemodel (= 3.2.8)
+ activesupport (= 3.2.8)
+ arel (~> 3.0.2)
+ tzinfo (~> 0.3.29)
+ activeresource (3.2.8)
+ activemodel (= 3.2.8)
+ activesupport (= 3.2.8)
+ activesupport (3.2.8)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ arel (3.0.2)
+ builder (3.0.3)
+ coffee-rails (3.2.2)
+ coffee-script (>= 2.2.0)
+ railties (~> 3.2.0)
+ coffee-script (2.2.0)
+ coffee-script-source
+ execjs
+ coffee-script-source (1.3.3)
+ erubis (2.7.0)
+ execjs (1.4.0)
+ multi_json (~> 1.0)
+ hike (1.2.1)
+ i18n (0.6.1)
+ journey (1.0.4)
+ jquery-rails (2.1.3)
+ railties (>= 3.1.0, < 5.0)
+ thor (~> 0.14)
+ json (1.7.5)
+ mail (2.4.4)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ mime-types (1.19)
+ multi_json (1.3.6)
+ polyglot (0.3.3)
+ rack (1.4.1)
+ rack-cache (1.2)
+ rack (>= 0.4)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.2)
+ rack (>= 1.0)
+ rails (3.2.8)
+ actionmailer (= 3.2.8)
+ actionpack (= 3.2.8)
+ activerecord (= 3.2.8)
+ activeresource (= 3.2.8)
+ activesupport (= 3.2.8)
+ bundler (~> 1.0)
+ railties (= 3.2.8)
+ railties (3.2.8)
+ actionpack (= 3.2.8)
+ activesupport (= 3.2.8)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (>= 0.14.6, < 2.0)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ sass (3.2.1)
+ sass-rails (3.2.5)
+ railties (~> 3.2.0)
+ sass (>= 3.1.10)
+ tilt (~> 1.3)
+ sprockets (2.1.3)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
+ sqlite3 (1.3.6)
+ thor (0.16.0)
+ tilt (1.3.3)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.33)
+ uglifier (1.3.0)
+ execjs (>= 0.3.0)
+ multi_json (~> 1.0, >= 1.0.2)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ coffee-rails (~> 3.2.1)
+ jquery-rails
+ rails (= 3.2.8)
+ sass-rails (~> 3.2.3)
+ sqlite3
+ uglifier (>= 1.0.3)
Oops, something went wrong.

0 comments on commit d1c1945

Please sign in to comment.