Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

fixed gemspec

  • Loading branch information...
commit da979a71d6e05bcb92d118af4600c5bb6e5789fb 1 parent 77194b0
@JakubOboza authored
View
2  .gitignore
@@ -0,0 +1,2 @@
+pkg
+pkg/*
View
4 Rakefile
@@ -2,7 +2,7 @@ require 'rubygems'
require 'rake'
-require File.dirname(__FILE__) + "/rblip.rb"
+require File.dirname(__FILE__) + "/lib/rblip.rb"
begin
require 'jeweler'
@@ -14,6 +14,8 @@ begin
gemspec.email = "jakub.oboza@gmail.com"
gemspec.homepage = "http://github.com/JakubOboza/rblip"
gemspec.authors = ["Jakub Oboza"]
+ gemspec.add_dependency "json", ">= 1.1.9"
+ gemspec.files.include %w( lib/rblip.rb )
end
rescue LoadError
puts "Jeweler not available. Install it with: sudo gem install jeweler"
View
1  lib/rblip.rb
@@ -0,0 +1 @@
+require File.dirname(__FILE__) + "/core.rb"
View
12 rblip.gemspec
@@ -15,6 +15,15 @@ Gem::Specification.new do |s|
s.extra_rdoc_files = [
"README"
]
+ s.files = [
+ "CHANGELOG",
+ "README",
+ "Rakefile",
+ "lib/core.rb",
+ "lib/rblip.rb",
+ "rblip.gemspec",
+ "test.rb"
+ ]
s.homepage = %q{http://github.com/JakubOboza/rblip}
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
@@ -26,9 +35,12 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<json>, [">= 1.1.9"])
else
+ s.add_dependency(%q<json>, [">= 1.1.9"])
end
else
+ s.add_dependency(%q<json>, [">= 1.1.9"])
end
end
View
1  rblip.rb
@@ -1 +0,0 @@
-require File.dirname(__FILE__) + "/lib/core.rb"
Please sign in to comment.
Something went wrong with that request. Please try again.