A Node.js module to download and "install" the FlexPMD infrastructure for linting/analyzing ActionScript/Flash/Flex/AIR code.
JavaScript ActionScript
Switch branches/tags
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
lib
test
.gitignore
.jshintrc
.npmignore
.travis.yml
Gruntfile.js
LICENSE-MIT
README.md
package.json
prepublish.js

README.md

flexpmd Build Status

A Node.js module to download and "install" the FlexPMD infrastructure for linting/analyzing ActionScript/Flash/Flex/AIR code.

Getting Started

Install the module with: npm install flexpmd

var flexlint = require('flexpmd');
console.log(flexlint.path);  // path to the main directory of JARs
console.log(flexlint.cmd);   // path to the JAR to use like a command line executable

External Dependencies

While this Node/NPM module does not have any external dependencies itself, the FlexPMD tool requires Java.

Examples

See the unit tests for example usage.

Contributing

In lieu of a formal styleguide, take care to maintain the existing coding style. Add unit tests for any new or changed functionality. Lint and test your code using Grunt.

Release History

  • 1.3.0-1: Published to NPM on 2014-03-05.
    • Added an .npmignore file as the defaults taken from .gitignore were bad.
  • 1.3.0-0: Published to NPM on 2014-02-23.
    • Initial release. Version number aligned with FlexPMD version number.

License

Copyright (c) 2014 James M. Greene
Licensed under the MIT license.

Background Information on FlexPMD