New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Issue] Entering custom values in "Move" and "Scale" #40

Closed
Mittagskogel opened this Issue Jul 1, 2017 · 6 comments

Comments

Projects
None yet
2 participants
@Mittagskogel

Mittagskogel commented Jul 1, 2017

Entering custom values in "Move" and "Scale" is very glitchy due to the way the values update in real time. For example, entering a value of 1.5 in any of the fields is nearly impossible.

@JannisX11

This comment has been minimized.

Owner

JannisX11 commented Jul 1, 2017

Are you sure you are in the latest version (1.5.0) ?

@Mittagskogel

This comment has been minimized.

Mittagskogel commented Jul 2, 2017

Yes, I am referring to the web app, version 1.5.0.

@JannisX11

This comment has been minimized.

Owner

JannisX11 commented Jul 2, 2017

Sorry but this works perfectly fine for me.
Does that mean you are not able to enter letters into the text field? Because you should be able.

@Mittagskogel

This comment has been minimized.

Mittagskogel commented Jul 2, 2017

This is what I do:

  1. Add Cube (in the Outliner).
  2. Click in Scale X to select the value.
  3. Type "1", then ".", then "5".
    After each character, the cursor jumps back to the beginning and the text is reformatted, so in the end, what actually happens after each character is: "1", "0.1", "50.1". After this, this, it "autocorrects" again, so that the final value is 32, because 50 is obviously much too large. (It autocorrects to 32 because I have set the scale to 0.5, and I am using the 32x32 grid)

Of course, dragging or clicking the arrows works just fine, also for decimal values, but it would be nice if typing in the values normally would also be possible.

I am using Mozilla Firefox 54.0.1 32-bit

@JannisX11

This comment has been minimized.

Owner

JannisX11 commented Jul 2, 2017

Thanks for the detailed explaination. The issue apparently only occurs in Firefox.
I will try to fix it of course, but I suggest to take a look at Chrome or Opera. Blockbench looks a lot better in them.

@JannisX11 JannisX11 changed the title from Entering custom values in "Move" and "Scale" to [Issue] Entering custom values in "Move" and "Scale" Jul 2, 2017

@JannisX11

This comment has been minimized.

Owner

JannisX11 commented Jul 8, 2017

Fixed in 1.6.5

@JannisX11 JannisX11 closed this Jul 8, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment