Permalink
Browse files

Release v2.9.1

  • Loading branch information...
jodastephen committed Nov 12, 2015
1 parent c0cbd65 commit 73fd550faa7b37ef31dd246752394cbb5f5543da
Showing with 126 additions and 25 deletions.
  1. +3 −3 README.md
  2. +9 −9 RELEASE-NOTES.txt
  3. +1 −1 pom.xml
  4. +9 −9 src/conf/MANIFEST.MF
  5. +3 −3 src/site/markdown/index.md
  6. +1 −0 src/site/xdoc/installation.xml
  7. +100 −0 src/site/xdoc/upgradeto291.xml
View
@@ -46,16 +46,16 @@ Various documentation is available:
### Releases
[Release 2.9](http://www.joda.org/joda-time/download.html) is the current latest release.
[Release 2.9.1](http://www.joda.org/joda-time/download.html) is the current latest release.
This release is considered stable and worthy of the 2.x tag.
It depends on JDK 1.5 or later.
Available in the [Maven Central repository](http://search.maven.org/#artifactdetails|joda-time|joda-time|2.9|jar)
Available in the [Maven Central repository](http://search.maven.org/#artifactdetails|joda-time|joda-time|2.9.1|jar)
<dependency>
<groupId>joda-time</groupId>
<artifactId>joda-time</artifactId>
<version>2.9</version>
<version>2.9.1</version>
</dependency>
View
@@ -4,7 +4,7 @@ Joda-Time version 2.9.1
Joda-Time is a date and time handling library that seeks to replace the JDK
Date and Calendar classes. For Java SE 8 and later, please use java.time instead.
This release contains enhancements, bug fixes and a time zone update.
This release contains one bug fix.
The release runs on JDK 5 or later.
Joda-Time is licensed under the business-friendly Apache License Version 2.
@@ -14,13 +14,13 @@ This is the same license as all of Apache, plus other open source projects such
** http://www.joda.org/joda-time/related.html **
Bug fixes since 2.9
-------------------
Bug fixes in 2.9.1
------------------
- Fix bug introduced by Long.MIN_VALUE and Long.MAX_VALUE changes [#328]
Enhancements since 2.8
----------------------
Enhancements in 2.9
-------------------
- Faster parsing of time-zone identifiers [#282]
- Added Interval.parseWithOffset(String) [#299, #296]
@@ -45,8 +45,8 @@ Enhancements since 2.8
- Better error message for interval constructor [#321]
Compatibility with 2.8
----------------------
Compatibility between 2.8 and 2.9
---------------------------------
Build system - Yes
Binary compatible - Yes
@@ -61,8 +61,8 @@ Data compatible - Yes
Semantic compatible - Yes
Bug fixes since 2.8
-------------------
Bug fixes in 2.9
----------------
- Fixed to handle JDK 8u60 [#288, #291]
Without this fix, formatting a time-zone will print "+00:00" instead of "GMT" for the GMT time-zone
View
@@ -9,7 +9,7 @@
<artifactId>joda-time</artifactId>
<packaging>jar</packaging>
<name>Joda-Time</name>
<version>2.9</version>
<version>2.9.1</version>
<description>Date and time library to replace JDK date handling</description>
<url>http://www.joda.org/joda-time/</url>
View
@@ -5,19 +5,19 @@ Specification-Vendor: Joda.org
Specification-Version: 2.9
Implementation-Vendor: Joda.org
Implementation-Title: org.joda.time
Implementation-Version: 2.9
Implementation-Version: 2.9.1
Implementation-Vendor-Id: org.joda
Bundle-ManifestVersion: 2
Bundle-Vendor: Joda.org
Bundle-Name: Joda-Time
Bundle-SymbolicName: joda-time
Bundle-Version: 2.9
Export-Package: org.joda.time;version=2.9,
org.joda.time.base;version=2.9,
org.joda.time.chrono;version=2.9,
org.joda.time.convert;version=2.9,
org.joda.time.field;version=2.9,
org.joda.time.format;version=2.9,
org.joda.time.tz;version=2.9
Bundle-Version: 2.9.1
Export-Package: org.joda.time;version=2.9.1,
org.joda.time.base;version=2.9.1,
org.joda.time.chrono;version=2.9.1,
org.joda.time.convert;version=2.9.1,
org.joda.time.field;version=2.9.1,
org.joda.time.format;version=2.9.1,
org.joda.time.tz;version=2.9.1
Bundle-License: Apache 2.0
Bundle-DocURL: http://www.joda.org/joda-time/
@@ -125,21 +125,21 @@ Joda-Time is licenced under the business friendly <a href="license.html">Apache
## <i></i> Releases
[Release 2.9](download.html) is the current latest release.
[Release 2.9.1](download.html) is the current latest release.
This release is considered stable and worthy of the 2.x tag.
See the [upgrade notes](upgradeto290.html) for full details.
Joda-Time requires Java SE 5 or later and has [no dependencies](dependencies.html).
There is a *compile-time* dependency on [Joda-Convert](http://www.joda.org/joda-convert/),
but this is not required at runtime thanks to the magic of annotations.
Available in [Maven Central](http://search.maven.org/#artifactdetails%7Cjoda-time%7Cjoda-time%7C2.9%7Cjar).
Available in [Maven Central](http://search.maven.org/#artifactdetails%7Cjoda-time%7Cjoda-time%7C2.9.1%7Cjar).
```xml
<dependency>
<groupId>joda-time</groupId>
<artifactId>joda-time</artifactId>
<version>2.9</version>
<version>2.9.1</version>
</dependency>
```
@@ -21,6 +21,7 @@ of the source code suitable for linking to the jar file in IDEs such as Eclipse.
<p>
The release notes for upgraders can be found here:
<ul>
<li><a href="upgradeto291.html">Version 2.9.1</a> - upgrade from Version 2.9</li>
<li><a href="upgradeto290.html">Version 2.9</a> - upgrade from Version 2.8</li>
<li><a href="upgradeto282.html">Version 2.8.2</a> - upgrade from Version 2.8.1</li>
<li><a href="upgradeto281.html">Version 2.8.1</a> - upgrade from Version 2.8</li>
@@ -0,0 +1,100 @@
<?xml version="1.0" encoding="ISO-8859-1"?>
<document>
<properties>
<title>Java date and time API - Upgrade from 2.8 to 2.9</title>
<author>Stephen Colebourne</author>
</properties>
<body>
<section name="Upgrade">
<p>
These are the release notes and advice for upgrading Joda-Time from version 2.8 to version 2.9.
<source>
Joda-Time version 2.9.1
-----------------------
Joda-Time is a date and time handling library that seeks to replace the JDK
Date and Calendar classes. For Java SE 8 and later, please use java.time instead.
This release contains one bug fix.
The release runs on JDK 5 or later.
Joda-Time is licensed under the business-friendly Apache License Version 2.
This is the same license as all of Apache, plus other open source projects such as Spring.
** Please also check out our related projects **
** http://www.joda.org/joda-time/related.html **
Bug fixes in 2.9.1
------------------
- Fix bug introduced by Long.MIN_VALUE and Long.MAX_VALUE changes [#328]
Enhancements in 2.9
-------------------
- Faster parsing of time-zone identifiers [#282]
- Added Interval.parseWithOffset(String) [#299, #296]
Provides a way to parse the fixed offset in an interval string
- Add DateTimeFormatter methods for StringBuilder [#298]
- Add Russian period translations [#320]
- Add Italian period translations [#312]
- Add Czech period translations [#313]
- Clarify that PeriodFormatterBuilder is in an invalid state once built [#309]
- Allow DateTime and Interval to refer to values at Long.MIN_VALUE and Long.MAX_VALUE [#297, #190]
A DateTime may be created with any millisecond value, however at the very edges there may be
some undesirable effects, for example always using UTC instead of the time-zone
- Better error message for malformed tzdb files [#319]
- Better error message for interval constructor [#321]
Compatibility between 2.8 and 2.9
---------------------------------
Build system - Yes
Binary compatible - Yes
Source compatible - Yes
Serialization compatible - Yes
Data compatible - Yes
- DateTimeZone data updated to version 2015g
Semantic compatible - Yes
Bug fixes in 2.9
----------------
- Fixed to handle JDK 8u60 [#288, #291]
Without this fix, formatting a time-zone will print "+00:00" instead of "GMT" for the GMT time-zone
- Fix parsing of basic form ISO style where year has unnecessary plus sign [#86]
For example, +20151030 will now be correctly parsed as year 2015.
- Fix overflow bug in intervals [#315]
Scala
-----
Joda-Time uses annotations from Joda-Convert.
In the Java programming language, this dependency is optional, however in Scala it is not.
Scala users must manually add the Joda-Convert v1.2 dependency.
</source>
</p>
</section>
</body>
</document>

0 comments on commit 73fd550

Please sign in to comment.