Language array issues #132

Closed
seancarew opened this Issue Jan 23, 2013 · 7 comments

Comments

Projects
None yet
3 participants

I started with a clean J2.5.8 site and installed the latest build from yesterday.

I installed languages.

They show in joomfish/content languages...I then tried to activate the languages and save.

I got the language array error...but a top few languages were now indicated as active.

I attempted to activate more languages...could not do so...same error.
Joom-Fish--Control-Panel
Joom-Fish--Joom-Fish-Language-Manager

Owner

akempkens commented Jan 24, 2013

Can you sent me a backup of your site? I looks like a quite complex one and good test environment.

Alex

Am 23.01.2013 um 07:10 schrieb Sean Carew notifications@github.com:

I started with a clean J2.5.8 site and installed the latest build from yesterday.

I installed languages.

They show in joomfish/content languages...I then tried to activate the languages and save.

I got the language array error...but a top few languages were now indicated as active.

I attempted to activate more languages...could not do so...same error.


Reply to this email directly or view it on GitHub.

Sure - no problem. I will send you an installer which has sample content...you can re-create my base site...please send me an email address

Member

klas commented Jan 27, 2013

I went for bug hunting (using trial&error method as nothing else worked )on sandbox site that you sent me -> issue is caused by multiple english languages you have installed. Unfortunately Joomfish won't work with multiple languages with the same iso short code, it works on presumption each language is represented only once.

To resolve this you will need to uninstall duplicate english language and truncate #_jf_languages_ext table

Owner

akempkens commented Feb 1, 2013

Klas do you think we should implement a save check to avoid this happening?

That would be a good idea. I am still not sure what I did to cause the error...perhaps a safety net.

@akempkens akempkens pushed a commit that referenced this issue Feb 3, 2013

Alex Kempkens #132 - fixing array issue with having a working array management inte…
…grated. Now the error occurs and the data is not lost


#123 - fixing order issue as existing languages will no longer be overwritten by frontend language information
+ special indication for new frontend languages that are not stored as content languages yet
+ additional language tags for not stored content languages
60939ff
Owner

akempkens commented Feb 3, 2013

I tested about 5 existing and non existing languages now. The issue should not occur anymore

akempkens closed this Feb 3, 2013

Thanks very much Alex - sent via Hojoki

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment