Skip to content
Find out if a given gem and version is outdated or not.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
bin
lib
spec
.gitignore
.rspec
.travis.yml
CHANGELOG.md
Gemfile
LICENSE.txt
README.md
Rakefile
gem_outdated.gemspec

README.md

GemOutdated

Build Status

Find out if a given gem and version is outdated or not.

Installation

Add this line to your application's Gemfile then bundle:

gem "gem_outdated"

Or install it yourself as:

$ gem install gem_outdated

Usage

Suppose latest Rails is 5.1.4.

# Tells latest when asked a outdated version
GemOutdated.outdated?("rails", "5.1.2")
=> "5.1.4"

# Already latest
GemOutdated.outdated?("rails", "5.1.4")
=> false

# Newer than latest
GemOutdated.outdated?("rails", "5.1.5.rc1")
=> false

# Returns false when Version not exists
GemOutdated.outdated?("rails", "1.2.3.4")
=> false

# Gem not exists raises an error
GemOutdated.outdated?("greatest_rails", "1.0.0")
=> GemOutdated::RubygemsAPI::GemNotFound

License, Contributor's Guidelines

You can’t perform that action at this time.