New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

hist2d not working #34

Closed
dlfivefifty opened this Issue Feb 1, 2014 · 3 comments

Comments

Projects
None yet
2 participants
@dlfivefifty

dlfivefifty commented Feb 1, 2014

I tried

PyPlot.hist2d(rand(10),rand(10))

but get an error:

m not defined
while loading In[13], in expression starting on line 1
in hist2d at /Users/solver/.julia/PyPlot/src/PyPlot.jl:243

@stevengj stevengj closed this in da562b7 Feb 1, 2014

@stevengj

This comment has been minimized.

Show comment
Hide comment
@stevengj

stevengj Feb 1, 2014

Collaborator

Should be fixed now, but now it's simply going to give a more informative error message: your matplotlib version apparently does not have a hist2d function.

Collaborator

stevengj commented Feb 1, 2014

Should be fixed now, but now it's simply going to give a more informative error message: your matplotlib version apparently does not have a hist2d function.

@dlfivefifty

This comment has been minimized.

Show comment
Hide comment
@dlfivefifty

dlfivefifty Feb 1, 2014

OK I updated matplotlib, but now get the error

PyError (PyObject_Call) <type 'exceptions.TypeError'>
TypeError('Julia exception: TypeError(:draw_if_interactive,"if",Bool,0)',)
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 2866, in hist
ax = gca()
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 815, in gca
ax = gcf().gca(**kwargs)
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 456, in gcf
return figure()
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 445, in figure
draw_if_interactive()

while loading In[2], in expression starting on line 1
in pyerr_check at /Users/solver/.julia/PyCall/src/exception.jl:58
in pycall at /Users/solver/.julia/PyCall/src/PyCall.jl:85
in fn at /Users/solver/.julia/PyCall/src/conversions.jl:181

Probably is an issue with my matplotlib installation though.

On 2 Feb 2014, at 3:16 am, Steven G. Johnson notifications@github.com wrote:

Should be fixed now, but now it's simply going to give a more informative error message: your matplotlib version apparently does not have a hist2d function.


Reply to this email directly or view it on GitHub.

dlfivefifty commented Feb 1, 2014

OK I updated matplotlib, but now get the error

PyError (PyObject_Call) <type 'exceptions.TypeError'>
TypeError('Julia exception: TypeError(:draw_if_interactive,"if",Bool,0)',)
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 2866, in hist
ax = gca()
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 815, in gca
ax = gcf().gca(**kwargs)
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 456, in gcf
return figure()
File "/Library/Python/2.7/site-packages/matplotlib-1.4.x-py2.7-macosx-10.9-intel.egg/matplotlib/pyplot.py", line 445, in figure
draw_if_interactive()

while loading In[2], in expression starting on line 1
in pyerr_check at /Users/solver/.julia/PyCall/src/exception.jl:58
in pycall at /Users/solver/.julia/PyCall/src/PyCall.jl:85
in fn at /Users/solver/.julia/PyCall/src/conversions.jl:181

Probably is an issue with my matplotlib installation though.

On 2 Feb 2014, at 3:16 am, Steven G. Johnson notifications@github.com wrote:

Should be fixed now, but now it's simply going to give a more informative error message: your matplotlib version apparently does not have a hist2d function.


Reply to this email directly or view it on GitHub.

@stevengj

This comment has been minimized.

Show comment
Hide comment
@stevengj

stevengj Feb 1, 2014

Collaborator

I don't think PyPlot works with matplotlib 1.4 (which is not actually released yet...you must be using a prerelease), at least not yet... use matplotlib 1.2 or 1.3.

Collaborator

stevengj commented Feb 1, 2014

I don't think PyPlot works with matplotlib 1.4 (which is not actually released yet...you must be using a prerelease), at least not yet... use matplotlib 1.2 or 1.3.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment