Permalink
Browse files

Merge pull request #107 from Azolo/dk_gemhook_require

RubyGems pre_install hook now uses require 'devkit'
  • Loading branch information...
2 parents ceef18d + f9bdde3 commit ded3058deb8d39c8dd7e5f9e35f4eca7028d63ba @luislavena luislavena committed Apr 13, 2012
Showing with 1 addition and 8 deletions.
  1. +1 −8 resources/devkit/dk.rb.erb
@@ -49,14 +49,7 @@ EOT
# #{DEVKIT_START} override 'gem install' to enable RubyInstaller DevKit usage
Gem.pre_install do |gem_installer|
unless gem_installer.spec.extensions.empty?
- unless ENV['PATH'].include?('#{d}\\\\mingw\\\\bin') then
- Gem.ui.say 'Temporarily enhancing PATH to include DevKit...' if Gem.configuration.verbose
- ENV['PATH'] = '#{d}\\\\bin;#{d}\\\\mingw\\\\bin;' + ENV['PATH']
- end
- ENV['RI_DEVKIT'] = '#{d}'
-<% tool_names.each_pair do |k,v| -%>
- <%= 'ENV[\'%s\'] = \'%s\'' % [k,v] %>
-<% end -%>
+ require 'devkit'
end
end
# #{DEVKIT_END}

0 comments on commit ded3058

Please sign in to comment.