Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master

May 15, 2012

  1. Jon

    Update mingw64-32-4.7.1 to 20120512-rev-187427

    jonforums authored

May 12, 2012

  1. Luis Lavena

    Doh

    Please ignore any commit done at 11pm on a friday...
    luislavena authored
  2. Luis Lavena

    Disable extra debug information from Ruby 1.9 builds

    Until Ruby debug flags get sorted out:
    
    http://bugs.ruby-lang.org/issues/6360
    luislavena authored

May 11, 2012

  1. Luis Lavena

    Update RDoc and rdoc_chm dependency

    Also update note on installing the right dependencies.
    luislavena authored
  2. Luis Lavena

    Merge branch 'Azolo-docs_config_refactor'

    luislavena authored

May 10, 2012

  1. Luis Lavena

    Merge branch 'docs_config_refactor' of https://github.com/Azolo/rubyi…

    …nstaller into Azolo-docs_config_refactor
    
    Conflicts:
    	config/ruby_installer.rb
    luislavena authored

May 09, 2012

  1. Luis Lavena

    Correct mingw-w64 4.6.3 to use latest stable release

    luislavena authored

May 08, 2012

  1. Justin Baker

    Use rake dependencies instead of if statements

    Closes GH #109
    
    Conflicts:
    
    	recipes/devkit/devkit.rake
    
    Signed-off-by: Jon <jon.forums@gmail.com>
    Azolo authored jonforums committed

May 06, 2012

  1. Jon

    Update DevKit mingw64-32-4.7.1

    jonforums authored

Apr 30, 2012

  1. Jon

    Update mingw64-32-4.7.1 to 20120430-rev-186947

    jonforums authored
  2. Jon

    The `devkit:ls` siren song was just too strong

    jonforums authored

Apr 29, 2012

  1. Jon

    Joy, another pretty-print `devkit:ls` OCD tweak ;)

    jonforums authored
  2. Jon

    Teach `devkit:ls` to show its default value

    jonforums authored
  3. Jon

    Add mingw64-32-4.7.1 (mingwbuilds) support

    jonforums authored
  4. Jon

    Add top-level Rake task to list valid DevKit's

    Thanks to @Azolo aka Justin Baker for suggesting
    jonforums authored
  5. Jon

    Refactor DevKit valid compilers checking

    Thanks to @Azolo aka Justin Baker for suggesting this refactor.
    jonforums authored
  6. Jon

    Refactor DevKit compiler initialization

    Refactor the `config/compilers/0001_dkcompiler_init.rb` init code
    into `config/devkit.rb`. Thanks to @Azolo aka Justin Baker for the
    idea.
    jonforums authored
  7. Luis Lavena

    Merge pull request #110 from Azolo/cleanup

    Cleanup a couple unused tasks/variables
    luislavena authored
  8. Jon

    Upgrade RubyGems to 1.8.24

    jonforums authored

Apr 28, 2012

  1. Justin Baker

    Removed non-functioning tasks

    Azolo authored
  2. Justin Baker

    Remove unused variable

    Azolo authored

Apr 23, 2012

  1. Jon

    Upgrade OpenSSL to version 1.0.0i

    Security Advisory: http://openssl.org/news/secadv_20120419.txt
    
    Switched downloads from ibiblio to main openssl.org site
    jonforums authored

Apr 22, 2012

  1. Jon

    Upgrade libffi to version 3.0.11

    jonforums authored

Apr 21, 2012

  1. Luis Lavena

    Prepare for 1.9.3-p194 announcement

    luislavena authored
  2. Luis Lavena

    Upgrade Ruby 1.9.3 to patchlevel 194

    Results of 'make check' here:
    https://gist.github.com/2438011
    luislavena authored

Apr 20, 2012

  1. Jon

    Upgrade RubyGems to 1.8.23

    jonforums authored

Apr 18, 2012

  1. Jon

    Upgrade RubyGems to 1.8.22

    jonforums authored
  2. Jon

    Merge pull request #108 from Azolo/dk_gemhook_require

    Moved DevKit Environment message to Gem Hook
    jonforums authored

Apr 17, 2012

  1. Justin Baker

    Use load instead of require

    Azolo authored
  2. Justin Baker

    Moved all messages to devkit.rb

    Azolo authored

Apr 15, 2012

  1. Justin Baker

    Added a $DEBUG message for devkit.rb

    Azolo authored

Apr 14, 2012

  1. Justin Baker

    Moved DevKit Environment message to Gem Hook

     * It no longer displays a message when simply using require 'devkit'
     * Fixes bug that causes Gem install to fail when require returns false
    Azolo authored

Apr 13, 2012

  1. Luis Lavena

    Merge pull request #107 from Azolo/dk_gemhook_require

    RubyGems pre_install hook now uses require 'devkit'
    luislavena authored
  2. Justin Baker

    RubyGems pre_install hook now uses require 'devkit'

    Azolo authored
  3. Justin Baker

    Edit doc recipe to use new refactored docs config

    Azolo authored
Something went wrong with that request. Please try again.