Permalink
Browse files

remove waf support

we are already requiring node >= 0.7.9, no sense in keep wscript around
  • Loading branch information...
1 parent 7dabf27 commit ba0b12e7fc70d1dd2aebf06aca08ca0f45590d5c @mscdex mscdex committed Mar 8, 2013
Showing with 1 addition and 37 deletions.
  1. +1 −1 Makefile
  2. +0 −36 wscript
View
@@ -20,6 +20,6 @@ docclean:
rm -fr docs/index.{json,html}
distclean:
- node-waf distclean
+ node-gyp clean
.PHONY: clean distclean test docs docclean
View
@@ -1,36 +0,0 @@
-import Options
-from os import unlink, link
-from os.path import exists
-
-APPNAME = 'zeromq.node'
-VERSION = "1.0.0"
-
-def set_options(opt):
- opt.tool_options("compiler_cxx")
-
-def configure(conf):
- conf.check_tool("compiler_cxx")
- conf.check_tool("node_addon")
- conf.check_cfg(atleast_pkgconfig_version='0.0.0', mandatory=True, errmsg='pkg-config was not found')
- conf.check_cfg(package='libzmq', atleast_version='2.1.0', uselib_store='ZMQ', args='--cflags --libs', mandatory=True, errmsg='Package libzmq was not found')
- conf.check(lib='uuid', uselib_store='UUID')
-
-def build(bld):
- obj = bld.new_task_gen("cxx", "shlib", "node_addon")
- obj.target = "binding"
- obj.source = "binding.cc"
- obj.uselib = "ZMQ UUID"
-
-def shutdown():
- # HACK to get binding.node out of build directory.
- # better way to do this?
- if exists('./binding.node'):
- unlink('./binding.node')
- if Options.commands['build']:
- if exists('./build/default/binding.node'):
- link('./build/default/binding.node', './binding.node')
- elif exists('./build/Release/binding.node'):
- link('./build/Release/binding.node', './binding.node')
- else:
- raise Exception("Cannot locate build binding.node")
-

0 comments on commit ba0b12e

Please sign in to comment.