installation error on fedora 16: npm install zmq fails #89

Closed
linuxnow opened this Issue Feb 14, 2012 · 1 comment

Projects

None yet

1 participant

@linuxnow

When I try to install it using npm it fails. Thje problem is the following one:

Checking for libzmq >= 2.1.0 : Package libzmq was not found

It was reported in issue #70, close two months ago, whre I've posted a comment that I copy here.

Same problem in f16. If I run it manually:

$ pkg-config --errors-to-stdout --print-errors libzmq
Package libzmq was not found in the pkg-config search path.
Perhaps you should add the directory containing `libzmq.pc'
to the PKG_CONFIG_PATH environment variable

But it's not installed, this is what fedora's rpm installs:

$ rpm -ql zeromq
/usr/lib64/libzmq.so.1
/usr/lib64/libzmq.so.1.0.0
/usr/share/doc/zeromq-2.1.9
/usr/share/doc/zeromq-2.1.9/AUTHORS
/usr/share/doc/zeromq-2.1.9/COPYING
/usr/share/doc/zeromq-2.1.9/COPYING.LESSER
/usr/share/doc/zeromq-2.1.9/ChangeLog
/usr/share/doc/zeromq-2.1.9/NEWS
/usr/share/doc/zeromq-2.1.9/README$ rpm -ql zeromq
/usr/lib64/libzmq.so.1
/usr/lib64/libzmq.so.1.0.0
/usr/share/doc/zeromq-2.1.9
/usr/share/doc/zeromq-2.1.9/AUTHORS
/usr/share/doc/zeromq-2.1.9/COPYING
/usr/share/doc/zeromq-2.1.9/COPYING.LESSER
/usr/share/doc/zeromq-2.1.9/ChangeLog
/usr/share/doc/zeromq-2.1.9/NEWS
/usr/share/doc/zeromq-2.1.9/README

There should be some other way to check for the dependency, or just ignore it, unless it's needed to build it.

I'm willing to quickly test it if you provide a solution.

Thanks
Pau

@linuxnow

My fault, I hadn't installed the devel package. wscript is fine, sorry for the noise.

@linuxnow linuxnow closed this Feb 27, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment