Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

CHANGELOG

hlb edited this page · 59 revisions

LATEST:

1.15: 2012-04-26

  • [ADD] "Open Project Folder" menu item
  • [ADD] bootstrap-sass compass extension
  • [UPDATE] Use Sass 3.1.16
  • [FIXES] compass-h5bp js issue #70
  • and some minor issues

1.14: 2012-03-15

  • [UPDATE] Use Compass 0.12.1
  • [FIXES] crashes when custom compass version is selected #69

1.13.2: 2012-03-13

  • [UPDATE] User can specify file extensions to monitor in liverelod
  • [UPDATE] Support https://github.com/livereload/livereload-js #58.
  • [UPDATE] Use compass-h5bp
  • [UPDATE] Use Sass 3.1.15, Compass 0.12, JRuby 1.6.7, SWT 3.7.2
  • [UPDATE] Drop Compass 0.11 support
  • [Fixes] JavaScript Content-Type issue #62. Thanks @kusako
  • [Fixes] crashes issue in v1.12 #57
  • and other minor enhancements

1.12: 2012-01-30

  • [FIXES] "undefined method 'uniq'" bug when you run "clean & compile"

1.11: 2011-12-29

  • [FIXES] Update em-websocket to make livereload work with latest Chrome version
  • [FIXES] Limit port number in preferences #47
  • [UPDATE] Provide a welcome dialog to new user #48
  • [UPDATE] Add experimental Vim omni complete support. See Editor Extension
  • [UPDATE] Use Sass 3.1.12, Compass 0.11.6/0.12.alpha.3, JRuby 1.6.5.1

1.10: 2011-12-5

  • [FIXES] Compass.app crashes when user choose "create project" then cancel it immediately #44
  • [UPDATE] minor UI enhancement #40
  • [UPDATE] Use Sass 3.1.11
  • [UPDATE] Use JRuby 1.6.5
  • [UPDATE] Use chunk_png 1.2.5
  • [UPDATE] HTML 5 Boilerplate 2.0 by https://github.com/heygrady/compass-html5-boilerplate (commit 4cc8815)
  • [UPDATE] Add experimental support Compass 0.12.alpha.2

1.9: 2011-10-6

  • [FIXES] Growl 1.3 support #33
  • [FIXES] Better handling config.rb #31
  • [UPDATE] Compass 960 plugin

1.8: 2011-8-27

  • [UPDATE] User can choose to use Sass or SCSS in preferences
  • [UPDATE] UI Change in preferences
  • [UPDATE] Use JRuby 1.6.4
  • [UPDATE] Use Sass 3.1.7
  • [FIXES] Update em-websocket to make livereload work with new WebSocket protocol

1.7: 2011-7-22

  • [UPDATE] OS X Lion Support

1.6: 2011-7-11

  • [UPDATE] Use JRuby 1.6.3
  • [UPDATE] Use Sass 3.1.4
  • [UPDATE] Use Compass 0.11.5
  • [UPDATE] Update run.sh in Linux version. Thanks @hstaugaard
  • [FIXES] User can install compass in path contains whitespace like "Program Files" now #23
  • [FIXES] fixes require issue #25

1.5: 2011-06-16

  • [UPDATE] User can set Sass output style, line comment, and debug_info options in GUI #4, #10
  • [UPDATE] User can clean history items in preferences
  • [UPDATE] User can clean and compile a project
  • [UPDATE] Drop Compass 0.10 support
  • [UPDATE] Use JRuby 1.6.2
  • [UPDATE] Use Compass 0.11.3

1.4: 2011-06-03

  • [UPDATE] Use compass-html5-boilerplate v1.0.0 in Compass 0.11 environment
  • [FIXES] Support Mac OS X 10.5
  • [FIXES] Support Windows 64bit version

1.3: 2011-05-03

  • [UPDATE] Use JRuby 1.6.1
  • [UPDATE] Use Sass 3.11.1 and Compass 0.11.1
  • [UPDATE] Use compass-html5-boilerplate 0.33 (HTML5Boilerplate 1.0)
  • [FIXES] Bugs when load compass extensions
  • [FIXES] Memory leak issues in Windows/Linux
  • [FIXES] Use event-machine gem in user's specific gem path instead of our own java version
  • [FIXES] Ensure rb-fsevent process stop correctly in Mac OS X

1.2: 2011-04-11

  • [UPDATE] Use JRuby 1.6.0 (faster)
  • [UPDATE] Use native FSEvent (faster and less CPU usage) in Snow Leopard
  • [UPDATE] Notification and log file is configurable
  • [UPDATE] Use Compass 0.11.beta.5 by default. User can still change to Compass 0.10.6, or use own gem path in preferences
  • [UPDATE] Added WEBrick support
  • [UPDATE] Added livereload support

1.1: 2011-01-13

  • [FIXES] Crashes when the required library is not available #2
  • [UPDATE] User can specify his own gem path in preference #3
  • [UPDATE] OSX version now support both 32bit and 64bit modes
  • [UPDATE] Better tray icons by evenwu
  • [UPDATE] Use orange tray icon when app is watching

1.0: 2010-12-30

first release.

Something went wrong with that request. Please try again.