Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LVS: CustomComparer not working #806

Closed
klayoutmatthias opened this issue May 24, 2021 · 0 comments
Closed

LVS: CustomComparer not working #806

klayoutmatthias opened this issue May 24, 2021 · 0 comments
Assignees
Milestone

Comments

@klayoutmatthias
Copy link
Collaborator

This is related to the following discussion:

https://www.klayout.de/forum/discussion/1821/how-to-create-a-genericdeviceparametercompare-subclass-for-lvs#latest

The CustomComparer isn't working because it's only installed on the extracted netlist and not on the schematic. Hence symmetry is broken and the internal error happens.

Technically the problem is that the extracted netlist's comparer is not copied to the schematic netlist because "clone" isn't available for scripted comparers.

In addition, the the "equal" method is redundant as - within the strict weak ordering - "equal(a,b)" is identical to "!less(a,b) && !less(b,a)".

@klayoutmatthias klayoutmatthias self-assigned this May 29, 2021
@klayoutmatthias klayoutmatthias added this to the 0.27.1 milestone May 29, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

1 participant