Skip to content
Permalink
Browse files

kdevelop packages 5.4.1

start of kdelibs4support removal, plan to check all, kinfocenter first
  • Loading branch information...
demmm committed Aug 13, 2019
1 parent 9e3e6dc commit 195afaeb556a83181f3a54b7dc585ca9d2ce04de
Showing with 13 additions and 11 deletions.
  1. +3 −3 kdev-php/PKGBUILD
  2. +3 −3 kdev-python/PKGBUILD
  3. +3 −3 kdevelop/PKGBUILD
  4. +4 −2 kinfocenter/PKGBUILD
@@ -1,7 +1,7 @@

pkgname=kdev-php
pkgver=5.4.0
_pkgver=5.4.0
pkgver=5.4.1
_pkgver=5.4.1
pkgrel=1
pkgdesc="PHP plugin for Kdevelop"
arch=('x86_64')
@@ -14,7 +14,7 @@ options=('!makeflags')
replaces=('kdevelop-php' 'kdevelop-php-docs')
conflicts=('kdevelop-php' 'kdevelop-php-docs')
source=("https://download.kde.org/stable/kdevelop/${_pkgver}/src/${pkgname}-${pkgver}.tar.xz")
sha256sums=('f77fc0918732fdd8ff6969a8fbb857bdd36de759d0f371cbb5e9803bde4ce675')
sha256sums=('7dc4a1f4e8521dfa85fce1ad736405e0dc1d25ad7b152587aaa50eb92c8cb992')

build() {
mkdir -p build
@@ -1,7 +1,7 @@

pkgname=kdev-python
pkgver=5.4.0
_pkgver=5.4.0
pkgver=5.4.1
_pkgver=5.4.1
pkgrel=1
pkgdesc='KDevelop plugin which provides Python language support.'
arch=('x86_64')
@@ -12,7 +12,7 @@ depends=('kdevelop' 'python3' 'ki18n' 'knewstuff' 'kitemmodels' 'threadweaver'
makedepends=('extra-cmake-modules' 'kdoctools' 'kdevelop-pg-qt')
groups=('kde' 'kdevelop-plugins')
source=("https://download.kde.org/stable/kdevelop/${_pkgver}/src/${pkgname}-${pkgver}.tar.xz")
sha256sums=('670ee6c5e0acbd10f5138f75470313716b9f7e94f0763261d3a77d1b93edaae6')
sha256sums=('b7dfe4d477eac8ef59f988ff471d3ea6169faac0c841bd93b0f981036ed47bd7')

build() {
mkdir -p build
@@ -1,7 +1,7 @@

pkgname=kdevelop
pkgver=5.4.0
_pkgver=5.4.0
pkgver=5.4.1
_pkgver=5.4.1
pkgrel=1
pkgdesc="A C/C++ development environment for KDE"
arch=('x86_64')
@@ -18,7 +18,7 @@ conflicts=('kdevplatform')
replaces=('kdevplatform')
groups=('programming')
source=("https://download.kde.org/stable/kdevelop/${_pkgver}/src/kdevelop-${pkgver}.tar.xz")
sha256sums=('94020746ee85a9b123f6b2b21c6b43c9ca5b79dc9e7e27c3544c39c3694f257e')
sha256sums=('6849c289ab9f4ad227cc4f4a52bf14e0eacab89ebf81020b0238d5ae607d388a')

prepare() {
cd ${pkgname}-${pkgver}
@@ -4,12 +4,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kinfocenter
pkgver=${_plasmaver}
pkgrel=1
pkgrel=2
pkgdesc='KInfocenter'
arch=('x86_64')
url='https://github.com/KDE/kinfocenter'
license=('LGPL')
depends=('glu' 'kcmutils' 'kdelibs4support' 'kemoticons' 'libraw1394' 'pciutils' 'plasma-framework' 'kwayland')
depends=('glu' 'kcompletion' 'kconfig' 'kconfigwidgets' 'kcoreaddons' 'kcrash' 'kdbusaddons' 'ki18n' 'kiconthemes'
'kcmutils' 'kio' 'kservice' 'solid' 'kwidgetsaddons' 'kxmlgui' 'kdeclarative' 'kpackage' 'libraw1394'
'pciutils' 'kwayland')
makedepends=('extra-cmake-modules' 'kdoctools')
groups=('kdeplasma5')
conflicts=('kde-workspace' 'about-distro')

0 comments on commit 195afae

Please sign in to comment.
You can’t perform that action at this time.