Skip to content
Permalink
Browse files

kdeconnect-kde add bluetooth support

continued kdelibs4support removal, clean-up & updated home url kross-interpreters, ktnef, ktuberling,
kturtle, kwordquiz, libkcompactdisc, plasma-sdk, umbrello
kdoctools
wire-desktop use sed line to not build rpm packages, now builds
  • Loading branch information...
demmm committed Aug 18, 2019
1 parent c0db0c1 commit 45b98a0403bddfca4766cc499a230dcd69840145
@@ -2,15 +2,15 @@
pkgname=kdeconnect-kde
pkgver=1.3.5
_pkgver=1.3.5
pkgrel=1
pkgrel=2
epoch=1
pkgdesc='KDE Connect adds communication between KDE and your smartphone'
url='https://github.com/KDE/kdeconnect-kde'
license=('GPL')
arch=('x86_64')
depends=('kcmutils' 'kconfigwidgets' 'kiconthemes' 'kdbusaddons' 'knotifications'
'kio' 'ki18n' 'kdeclarative' 'kwayland' 'qca-qt5' 'libfakekey'
'qt5-quickcontrols' 'telepathy-qt5' 'kirigami' 'sshfs')
'qt5-quickcontrols' 'qt5-connectivity' 'telepathy-qt5' 'kirigami' 'sshfs')
makedepends=('extra-cmake-modules' 'kdoctools')
conflicts=('kf5-kdeconnect-kde')
replaces=('kf5-kdeconnect-kde')
@@ -36,7 +36,8 @@ build() {
-DKDE_INSTALL_SYSCONFDIR=/etc \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF \
-DEXPERIMENTALAPP_ENABLED=ON
-DEXPERIMENTALAPP_ENABLED=ON \
-DBLUETOOTH_ENABLED=ON
make
}

@@ -4,15 +4,15 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kdoctools
pkgver=${_kf5ver}
pkgrel=1
pkgrel=2
pkgdesc='KDocTools'
arch=('x86_64')
url='https://projects.kde.org/projects/frameworks/kdoctools-git'
url='https://community.kde.org/Frameworks'
license=('LGPL')
depends=('karchive' 'docbook-xsl')
makedepends=('extra-cmake-modules' 'ki18n' 'perl-uri')
groups=('kf5')
source=("http://download.kde.org/stable/frameworks/5.15/${pkgname}-${pkgver}.tar.xz")
source=("https://download.kde.org/stable/frameworks/5.61/${pkgname}-${pkgver}.tar.xz")
md5sums=(`grep ${pkgname}-${_kf5ver}.tar.xz ../kf5.md5 | cut -d" " -f1`)

build() {
@@ -22,13 +22,13 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
-DKDE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build

make DESTDIR="${pkgdir}" install
make DESTDIR=${pkgdir} install
}
@@ -4,20 +4,16 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kross-interpreters
pkgver=${_kdever}
pkgrel=1
pkgdesc="KDE interpreters for Kross"
url="http://kde.org/"
pkgrel=2
pkgdesc="Language interpreters to enable in-process scripting with Kross."
url="https://kde.org/applications/development/"
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
depends=('kdelibs4support' 'kross' 'python2')
depends=('kross' 'python2' 'ruby')
makedepends=('extra-cmake-modules' 'kdoctools')
groups=('kde' 'kde-bindings' 'kde-uninstall')
provides=('kdebindings-kross-interpreters')
replaces=('kdebindings-kross-interpreters')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
md5sums=(`grep ${pkgname}-$_kdever.tar.xz ../kde-sc.md5 | cut -d" " -f1`)
#source=("git://anongit.kde.org/kross-interpreters.git")
#md5sums=('SKIP')

build() {
mkdir -p build
@@ -26,10 +22,7 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSYSCONF_INSTALL_DIR=/etc \
-DPLUGIN_INSTALL_DIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DLIB_INSTALL_DIR=lib
-DKDE_INSTALL_PLUGINDIR=/usr/lib/qt5/plugins
make
}

@@ -4,35 +4,29 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=ktnef
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Library that contains an API for the handling of TNEF data."
arch=('x86_64')
url='https://projects.kde.org/projects/kde/pim/ktnef'
url='https://kontact.kde.org/'
license=('LGPL')
depends=('kdelibs4support' 'kcalcore' 'kcalutils' 'kcontacts')
makedepends=('extra-cmake-modules' 'kdoctools' 'git')
depends=('ki18n' 'kcalcore' 'kcalutils' 'kcontacts')
makedepends=('extra-cmake-modules' 'kdoctools')
source=($_mirror/${pkgname}-${_kdever}.tar.xz)
md5sums=(`grep ${pkgname}-${_kdever}.tar.xz ../kde-sc.md5 | cut -d" " -f1`)
#source=("git://anongit.kde.org/ktnef.git")
#md5sums=('SKIP')

prepare() {
cd $pkgname-${pkgver}
#sed -i -e 's/${DATA_INSTALL_DIR}/${KXMLGUI_INSTALL_DIR}/' ${srcdir}/${pkgname}/src/CMakeLists.txt
}

build() {
mkdir build
mkdir -p build

cd build
cmake ../${pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DQML_INSTALL_DIR=/usr/lib/qt5/qml \
-DPLUGIN_INSTALL_DIR=/usr/lib/qt5/plugins \
-DBUILD_TESTING=OFF
make
}
@@ -4,23 +4,17 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=ktuberling
pkgver=${_kdever}
#pkgver=15.03.70
pkgrel=1
pkgrel=2
pkgdesc="Potato-Man, constructor game suitable for children and adults alike"
arch=('x86_64')
url='http://www.kde.org'
url='https://kde.org/applications/games/org.kde.ktuberling'
license=('GPL' 'LGPL' 'FDL')
depends=('kcoreaddons' 'kconfig' 'kitemmodels' 'kwidgetsaddons' 'kwindowsystem' 'kdbusaddons' 'ki18n'
'kconfigwidgets' 'ktextwidgets' 'kxmlgui' 'kio' 'knotifyconfig' 'knewstuff' 'kdelibs4support'
'libkdegames' 'phonon-qt5')
makedepends=('pkg-config' 'extra-cmake-modules' 'kdoctools')
depends=('kcompletion' 'kconfigwidgets' 'kcoreaddons' 'kcrash' 'kdbusaddons' 'kio' 'ki18n' 'kwidgetsaddons'
'kxmlgui' 'libkdegames' 'phonon-qt5')
makedepends=('extra-cmake-modules' 'kdoctools')
groups=('kde' 'kde-games' 'kde-uninstall' 'kaos-kids')
conflicts=('kdegames-ktuberling')
replaces=('kdegames-ktuberling')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
md5sums=(`grep ${pkgname}-$_kdever.tar.xz ../kde-sc.md5 | cut -d" " -f1`)
#source=("git://anongit.kde.org/ktuberling#branch=frameworks")
#md5sums=('SKIP')

prepare() {
cd $pkgname-${pkgver}
@@ -34,9 +28,6 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
-DPLUGIN_INSTALL_DIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF
make
}
@@ -45,4 +36,4 @@ package() {
cd build

make DESTDIR=${pkgdir} install
}
}
@@ -4,16 +4,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kturtle
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Educational Programming Environment"
url="http://kde.org/applications/education/kturtle/"
url="https://kde.org/applications/education/org.kde.kturtle"
arch=('x86_64')
url='http://www.kde.org'
license=('GPL' 'LGPL' 'FDL')
depends=('kio' 'knewstuff' 'ki18n' 'kdelibs4support')
depends=('kcrash' 'kio' 'knewstuff' 'ktextwidgets' 'ki18n' 'kcoreaddons')
makedepends=('extra-cmake-modules' 'kdoctools')
conflicts=('kdeedu-kturtle')
replaces=('kdeedu-kturtle')
groups=('kde' 'kde-edu' 'kde-uninstall' 'education')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
md5sums=(`grep ${pkgname}-$_kdever.tar.xz ../kde-sc.md5 | cut -d" " -f1`)
@@ -25,10 +23,7 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
-DSYSCONF_INSTALL_DIR=/etc \
-DQML_INSTALL_DIR=/usr/lib/qt5/qml \
-DPLUGIN_INSTALL_DIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_SYSCONFDIR=/etc \
-DBUILD_TESTING=OFF
make
}
@@ -4,17 +4,15 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kwordquiz
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Flash Card Trainer"
url="http://kde.org/applications/education/kwordquiz/"
url="https://kde.org/applications/education/org.kde.kwordquiz"
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
depends=('ki18n' 'kcrash' 'sonnet' 'kconfig' 'kconfigwidgets' 'kguiaddons' 'kiconthemes' 'kitemviews'
'knotifyconfig' 'kio' 'knewstuff' 'knotifications' 'kxmlgui' 'kdelibs4support' 'kdeclarative'
'knotifyconfig' 'knewstuff' 'knotifications' 'kwindowsystem' 'kxmlgui'
'libkeduvocdocument' 'phonon-qt5')
makedepends=('extra-cmake-modules' 'kdoctools')
conflicts=('kdeedu-kwordquiz')
replaces=('kdeedu-kwordquiz')
groups=('kde' 'kde-edu' 'kde-uninstall' 'education')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
md5sums=(`grep ${pkgname}-$_kdever.tar.xz ../kde-sc.md5 | cut -d" " -f1`)
@@ -31,9 +29,6 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
-DPLUGIN_INSTALL_DIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF
make
}
@@ -4,27 +4,25 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=libkcompactdisc
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="A library for interfacing with CDs"
url='https://github.com/KDE/libkcompactdisc'
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
depends=('ki18n' 'kcrash' 'kcoreaddons' 'kio' 'solid' 'kdelibs4support')
depends=('kcoreaddons' 'solid' 'ki18n' 'phonon-qt5')
makedepends=('extra-cmake-modules' 'kdoctools')
groups=('kde-multimedia')
source=("$_mirror/${pkgname}-${_kdever}.tar.xz")
md5sums=(`grep ${pkgname}-${_kdever}.tar.xz ../kde-sc.md5 | cut -d" " -f1`)

build() {
mkdir build
mkdir -p build

cd build
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_PLUGINDIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
-DKDE_INSTALL_LIBDIR=lib
make
}

@@ -5,17 +5,16 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=plasma-sdk
arch=('x86_64')
pkgver=${_plasmaver}
pkgrel=1
pkgrel=2
pkgdesc="Applications useful for Plasma Development."
url="https://github.com/KDE/plasma-sdk"
license=('GPL' 'LGPL' 'FDL')
depends=('karchive' 'kcompletion' 'kconfig' 'kconfigwidgets' 'kcoreaddons' 'kdbusaddons'
'kdeclarative' 'ki18n' 'kiconthemes' 'kitemmodels' 'kio' 'knewstuff' 'kparts'
'plasma-framework' 'kservice' 'ktexteditor' 'kwidgetsaddons' 'kxmlgui' 'kwindowsystem'
'kirigami' 'kdelibs4support' 'qt5-webkit')
'kirigami')
makedepends=('extra-cmake-modules' 'kdoctools')
source=($_mirror/${pkgname}-${_plasmaver}.tar.xz)
#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/KDE/${pkgname}/archive/${_branch}.tar.gz")
md5sums=(`grep ${pkgname}-${_plasmaver}.tar.xz ../kf5.md5 | cut -d" " -f1`)

build() {
@@ -25,11 +24,7 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_SYSCONFDIR=/etc \
-DKDE_INSTALL_QMLDIR=/usr/lib/qt5/qml \
-DKDE_INSTALL_PLUGINDIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF
make
}
@@ -6,15 +6,13 @@ pkgname=umbrello
pkgver=${_kdever}
pkgrel=1
pkgdesc='UML modeling tool for KDE'
url='http://kde.org/applications/development/umbrello/'
url='https://kde.org/applications/development/org.kde.umbrello'
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
depends=('karchive' 'kauth' 'kcompletion' 'kconfig' 'kcoreaddons' 'kguiaddons' 'ki18n' 'kiconthemes' 'kinit'
'kio' 'kparts' 'kservice' 'ktexteditor' 'kwindowsystem' 'kwidgetsaddons' 'kxmlgui' 'qt5-webkit' 'kdelibs4support')
makedepends=('extra-cmake-modules' 'kdoctools' 'boost') # 'clang')
groups=('kde' 'kde-sdk' 'kde-uninstall' 'programming' )
conflicts=('kdesdk-umbrello')
replaces=('kdesdk-umbrello')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
md5sums=(`grep ${pkgname}-${_kdever}.tar.xz ../kde-sc.md5 | cut -d" " -f1`)

@@ -30,9 +28,6 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_PLUGINDIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF \
-DBUILD_UNITTESTS=0 \
-DBUILD_KF5=ON
@@ -43,7 +38,5 @@ package() {
cd build

make DESTDIR=${pkgdir} install

#sed -i -e 's|-qwindowtitle|-caption|' ${pkgdir}/usr/share/applications/org.kde.umbrello.desktop
}

@@ -17,8 +17,8 @@ build() {
cd ${pkgname}-linux-${pkgver}

yarn
yarn build:linux
#npx grunt 'linux-other'
sed -i '/Promise.all/d' node_modules/@wireapp/build-tools/dist/cli/build-linux-cli.js
LINUX_TARGET=dir yarn build:linux
}

package() {

0 comments on commit 45b98a0

Please sign in to comment.
You can’t perform that action at this time.