Skip to content
Permalink
Browse files

new 19.08.0 tars for dolphin, kate, krfb

kdepim-runtime new tar & remove kdelibs4support depend
continued kdelibs4support removal apps, bovo, kalarm, kalzium, ktp-common-internals, ktp-contact-list
polkit-kde-agent-1
juk depends check
  • Loading branch information...
demmm committed Aug 13, 2019
1 parent 195afae commit 8bfe9beb383da6ca9bfca75ea5c30b45a2f9a368
@@ -5,13 +5,13 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=bovo
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Five-in-a-row Board Game"
arch=('x86_64')
url='http://www.kde.org'
license=('GPL' 'LGPL' 'FDL')
depends=('libkdegames' 'kcoreaddons' 'kxmlgui' 'knewstuff' 'kdeclarative' 'kdelibs4support')
makedepends=('pkg-config' 'extra-cmake-modules' 'kdoctools' 'git')
depends=('libkdegames' 'kcoreaddons' 'kcrash' 'kdbusaddons' 'kxmlgui' )
makedepends=('pkg-config' 'extra-cmake-modules' 'kdoctools')
groups=('kde' 'kdegames' 'kde-uninstall')
conflicts=('kdegames-bovo')
replaces=('kdegames-bovo')
@@ -28,10 +28,10 @@ build() {
cmake ../${pkgname}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=lib \
-DSYSCONF_INSTALL_DIR=/etc \
-DQML_INSTALL_DIR=/usr/lib/qt5/qml \
-DPLUGIN_INSTALL_DIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_SYSCONFDIR=/etc \
-DKDE_INSTALL_QMLDIR=/usr/lib/qt5/qml \
-DKDE_INSTALL_PLUGINDIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF
make
@@ -4,7 +4,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=dolphin
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="KDE File Manager"
arch=('x86_64')
url='https://projects.kde.org/projects/kde/applications/dolphin'
@@ -9,7 +9,7 @@ pkgdesc='A jukebox, tagger and music collection manager'
url='http://kde.org/applications/multimedia/juk/'
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
depends=('kcoreaddons' 'kcompletion' 'kconfig' 'kcrash' 'kglobalaccel' 'ki18n' 'kiconthemes'
depends=('kcoreaddons' 'kcompletion' 'kconfig' 'kcrash' 'kglobalaccel' 'ki18n' 'kiconthemes' 'kdbusaddons'
'kio' 'kjobwidgets' 'knotifications' 'ktextwidgets' 'kxmlgui' 'kwallet' 'kwidgetsaddons'
'kwindowsystem' 'qt5-svg' 'taglib')
makedepends=('extra-cmake-modules' 'kdoctools')
@@ -4,16 +4,16 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kalarm
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Application to manage alarms and other timer based alerts for the desktop."
arch=('x86_64')
url='https://github.com/KDE/kalarm'
license=('LGPL')
depends=('kauth' 'kcodecs' 'kcompletion' 'kconfig' 'kconfigwidgets' 'kdbusaddons' 'kglobalaccel' 'kguiaddons'
'ki18n' 'kiconthemes' 'kjobwidgets' 'kcmutils' 'kdelibs4support' 'kio' 'knotifications'
'kservice' 'kwidgetsaddons' 'kwindowsystem' 'kxmlgui'
'ki18n' 'kiconthemes' 'kjobwidgets' 'kcmutils' 'kio' 'knotifications'
'kservice' 'kwidgetsaddons' 'kwindowsystem' 'kxmlgui' 'kholidays'
'akonadi' 'akonadi-contacts' 'akonadi-mime' 'kalarmcal' 'kcalcore' 'kcalutils'
'kholidays' 'kidentitymanagement' 'kdepim-apps-libs' 'libkdepim' 'mailcommon'
'kidentitymanagement' 'kdepim-apps-libs' 'libkdepim' 'mailcommon'
'kmailtransport' 'kmime' 'pimcommon' 'kpimtextedit'
'libxslt'
'akonadi-import-wizard' 'pim-data-exporter')
@@ -4,14 +4,13 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kalzium
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Periodic Table of Elements"
url="https://kde.org/applications/education/kalzium/"
arch=('x86_64')
license=('GPL' 'LGPL' 'FDL')
depends=('avogadrolibs' 'eigen3' 'ocaml' 'openbabel'
'karchive' 'kconfig' 'kcoreaddons' 'ki18n' 'kdelibs4support' 'khtml'
'knewstuff' 'kparts' 'kplotting' 'solid' 'kunitconversion' 'kwidgetsaddons')
depends=('avogadrolibs' 'eigen3' 'ocaml' 'openbabel' 'karchive' 'kconfig' 'kcoreaddons' 'ki18n'
'khtml' 'kparts' 'kplotting' 'solid' 'kunitconversion' 'kwidgetsaddons' 'knewstuff')
makedepends=('extra-cmake-modules' 'kdoctools' 'facile')
groups=('kde' 'kde-edu' 'kde-uninstall' 'education')
source=("$_mirror/${pkgname}-${_kdever}.tar.xz")
@@ -4,7 +4,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kate
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc='Advanced editor component which is used in numerous KDE applications requiring a text editing component'
arch=('x86_64')
url='https://projects.kde.org/projects/kde/applications/kate'
@@ -19,7 +19,7 @@ abfe18e930ccca255c5bf82de8905df9 bomber-19.08.0.tar.xz
ba6437d359bfc89e7c20c446b317ff4c calendarsupport-19.08.0.tar.xz
04c94a65f52115065a981198fe1f95ef cantor-19.08.0.tar.xz
f4995f5544065cb3a4149544bb3f8af2 cervisia-19.08.0.tar.xz
16e150fde5aacc3f27661798f7b1c59b dolphin-19.08.0.tar.xz
2c9aebc32016b521f62cb73e34c92635 dolphin-19.08.0.tar.xz
032a73a5293f47e2e743fc71b34a6d89 dolphin-plugins-19.08.0.tar.xz
0b8ac2d21caac785824241d25df3c48f dragon-19.08.0.tar.xz
e1680d5302a02459fa4ab7c435b95b5c eventviews-19.08.0.tar.xz
@@ -45,7 +45,7 @@ cebfc317945a6820ea428877b25ed1e0 kalzium-19.08.0.tar.xz
48c2106ad773e2f8437b227787818656 kanagram-19.08.0.tar.xz
3c9728c22c737d9cd69ccf2c6ba8d0e8 kapman-19.08.0.tar.xz
24d56ecf4f5245594eeb5406fc421b17 kapptemplate-19.08.0.tar.xz
b60b884b724dfe663cfa7b8daa0d8f70 kate-19.08.0.tar.xz
b1fc6858905a84f3c4818b57c67af861 kate-19.08.0.tar.xz
70795d40845ce31ccc6cbbedc159b1f5 katomic-19.08.0.tar.xz
90266cad1cf74770d02fdcd850ba38e5 kbackup-19.08.0.tar.xz
de880a1d1bceb7a45c04ffeb64181631 kblackbox-19.08.0.tar.xz
@@ -73,7 +73,7 @@ da76165954d05aa6cbe70b95f09f919e kdegraphics-thumbnailers-19.08.0.tar.xz
92ed819162e80ad09f04ad73adb29519 kdenlive-19.08.0.tar.xz
f298c00b04efde5b32036e0df4438c38 kdepim-addons-19.08.0.tar.xz
9480e6e20af709e13044b636cbac7379 kdepim-apps-libs-19.08.0.tar.xz
bb6968dec04e6c19bca47ebfefa6019d kdepim-runtime-19.08.0.tar.xz
7e42634bcae9232679787cd1512affac kdepim-runtime-19.08.0.tar.xz
7c53dbb727dc3245911b15cb3b6ca575 kdesdk-kioslaves-19.08.0.tar.xz
f96b3eb910c114e822c32c128643fd48 kdesdk-thumbnailers-19.08.0.tar.xz
821e1086f5283e8d5bbc423aa177609d kdf-19.08.0.tar.xz
@@ -140,7 +140,7 @@ cbb541715e6d733e698967d8769a6265 kpimtextedit-19.08.0.tar.xz
87f9e9f8428f5bc0cf42d873d71d0154 kqtquickcharts-19.08.0.tar.xz
34ac4b23f9b7e6787ea5773f603b5960 krdc-19.08.0.tar.xz
ccdc91c6337c72cb0797fa80f39aae88 kreversi-19.08.0.tar.xz
1071a8ae43352bc507649843deb17807 krfb-19.08.0.tar.xz
0ef7c0f88f957efeb93d5dd5a487c780 krfb-19.08.0.tar.xz
61db59b0b40866fd1afda83718e477c5 kross-interpreters-19.08.0.tar.xz
1090b49451febfd8b93aec13a676dd14 kruler-19.08.0.tar.xz
d848ad60834902eb9cb2d64a4a3a4bec kshisen-19.08.0.tar.xz
@@ -4,13 +4,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=kdepim-runtime
pkgver=${_kdever}
pkgrel=1
pkgrel=2
arch=('x86_64')
pkgdesc="KDE Pim Runtime"
url="http://www.kde.org"
license=('GPL' 'LGPL' 'FDL')
depends=('akonadi-mime' 'akonadi-notes' 'akonadi-contacts' 'knotifyconfig' 'knewstuff' 'kcmutils'
'kdelibs4support' 'kconfig' 'kio' 'kitemmodels' 'kcodecs' 'accountsqt' 'signonqt' 'shared-mime-info'
depends=('akonadi-mime' 'akonadi-notes' 'akonadi-contacts' 'kconfig' 'kconfigwidgets' 'knotifyconfig' 'kio'
'kitemmodels' 'kcodecs' 'kwindowsystem' 'ktextwidgets' 'knotifications' 'kholidays' 'kdbusaddons' 'kiconthemes'
'accountsqt' 'signonqt' 'shared-mime-info'
'akonadi' 'kmime' 'kmailtransport' 'kidentitymanagement' 'kcontacts' 'kalarmcal' 'kcalcore'
'kcalutils' 'kmbox' 'kimap' 'syndication' 'akonadi-calendar' 'kaccounts-integration' 'pimcommon'
'kdav' 'libkgapi' 'libkolab' 'qtwebkit-tp' 'qca-qt5' 'qt5-networkauth')
@@ -5,7 +5,7 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
pkgname=krfb
pkgver=${_kdever}
#pkgver=15.11.74
pkgrel=1
pkgrel=2
pkgdesc='Desktop Sharing Server'
url='http://www.kde.org/applications/system/krfb'
arch=('x86_64')
@@ -18,8 +18,6 @@ replaces=('kdenetwork-krfb')
groups=('kde' 'kde-network' 'kde-uninstall' 'network')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
md5sums=(`grep ${pkgname}-$_kdever.tar.xz ../kde-sc.md5 | cut -d" " -f1`)
#source=("git://anongit.kde.org/krfb.git")
#md5sums=('SKIP')

build() {
mkdir build
@@ -4,13 +4,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=ktp-common-internals
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Common libraries for telepathy-kde"
arch=('x86_64')
url="https://projects.kde.org/projects/extragear/network/telepathy/ktp-common-internals"
license=('GPL')
depends=('kcmutils' 'knotifyconfig' 'ktexteditor' 'kwallet' 'kconfig' 'kdelibs4support'
'telepathy-qt5' 'telepathy-mission-control' 'kpeople' 'kcontacts' 'kaccounts-integration'
depends=('kcoreaddons' 'knotifications' 'kio' 'kwidgetsaddons' 'kcmutils' 'knotifyconfig'
'ktexteditor' 'kwallet' 'kconfig' 'kwindowsystem' 'kiconthemes' 'kpeople'
'telepathy-qt5' 'telepathy-mission-control' 'kcontacts' 'kaccounts-integration'
'libotr' 'telepathy-logger-qt5' 'telepathy-accounts-signon')
makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'boost')
groups=('kde-telepathy')
@@ -4,14 +4,14 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=ktp-contact-list
pkgver=${_kdever}
pkgrel=1
pkgrel=2
pkgdesc="Telepathy contact list application "
arch=('x86_64')
url="http://www.kde.org"
license=('GPL')
depends=('kdbusaddons' 'kio' 'kcmutils' 'knotifyconfig' 'kdelibs4support' 'ktp-common-internals'
'telepathy-qt5' 'kpeople')
makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'boost')
depends=('kdbusaddons' 'kio' 'kcmutils' 'knotifications' 'kwindowsystem' 'knotifyconfig' 'ki18n'
'kiconthemes' 'kxmlgui' 'kpeople' 'ktp-common-internals' 'telepathy-qt5')
makedepends=('extra-cmake-modules' 'kdoctools' 'boost')
groups=('kde-telepathy' 'communication')
#source=("ftp://mirrors.mit.edu/kde/stable/kde-telepathy/${pkgver}/src/${pkgname}-${pkgver}.tar.bz2")
conflicts=('kf5-ktp-contact-list')
@@ -4,12 +4,12 @@ source ../_buildscripts/${current_repo}-${_arch}-cfg.conf

pkgname=polkit-kde-agent-1
pkgver=${_plasmaver}
pkgrel=1
pkgrel=2
pkgdesc='Daemon providing a polkit authentication UI for KDE.'
arch=('x86_64')
url='https://github.com/KDE/polkit-kde-agent-1'
license=('LGPL')
depends=('ki18n' 'kwindowsystem' 'kdelibs4support' 'polkit-qt5')
depends=('ki18n' 'kwindowsystem' 'kdbusaddons' 'kwidgetsaddons' 'kcoreaddons' 'kcrash' 'kiconthemes' 'polkit-qt5')
makedepends=('extra-cmake-modules' 'kdoctools')
groups=('kdeplasma5')
source=("https://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.tar.xz")
@@ -25,7 +25,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_LIBEXECDIR=lib \
-DSKDE_INSTALL_SYSCONFDIR=/etc \
-DKDE_INSTALL_SYSCONFDIR=/etc \
-DKDE_INSTALL_QMLDIR=/usr/lib/qt5/qml \
-DKDE_INSTALL_PLUGINDIR=/usr/lib/qt5/plugins \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \

0 comments on commit 8bfe9be

Please sign in to comment.
You can’t perform that action at this time.