New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Please update to opencascade 7.3.0 #169

Closed
luzpaz opened this Issue Nov 28, 2018 · 5 comments

Comments

Projects
None yet
2 participants
@luzpaz

luzpaz commented Nov 28, 2018

Submission type

  • Bug report
  • Feature Request

Package name & version you are having issues with or have a request for

https://github.com/KaOSx/apps/blob/master/opencascade/PKGBUILD

Used repositories

Expected behaviour

Arch package

Actual behaviour

KaOS package

Steps to reproduce the problem

System info link created by Octopi > Tools > SysInfo

…the latest version

@demmm

This comment has been minimized.

demmm commented Nov 28, 2018

Please use the Online Package Viewer to flag packages.
https://kaosx.us/packages/
https://kaosx.us/packages/view.php?repo=apps&name=opencascade-1:6.9.1-2
Plus no idea what Arch has to do with anything in KaOS.

@demmm demmm closed this Nov 28, 2018

@luzpaz

This comment has been minimized.

luzpaz commented Nov 28, 2018

Thanks, I flagged it.
Just showing you that repology tracks a large portion of the package ecosystem and flags up to date and out of date packages. In this case Arch was showing an up to date version.

Edit: just a thought: you may want to add to your github PR template what you wrote to me above for folks wanting to flag out of date packages?

Please use the Online Package Viewer to flag out of date packages.  
https://kaosx.us/packages/
@demmm

This comment has been minimized.

demmm commented Nov 28, 2018

Opencascade was actually the only leftover dependency of the once in the repos "freecad". That one was removed 2-3 years ago. Opencascade will be removed now too. Might re-enter if a need from users is expressed to re-add freecad (which is now possible since it is Qt 5 based).

https://forum.kaosx.us/d/1469-qt-4-removal/

@luzpaz

This comment has been minimized.

luzpaz commented Nov 28, 2018

Good to know. Coincidentally, I'm trying to get FreeCAD better support in the package ecosystem https://github.com/luzpaz/FreeCAD-dependencies/
I'll start a thread on the KaOS forums guaging interest of the community to support a KaOS FreeCAD package. Thanks for the heads up.

Edit: oh yea.. github linked the above repo already, so you knew that. duh. sorry for the noise.

@luzpaz

This comment has been minimized.

luzpaz commented Nov 28, 2018

Also 1 more FYI, repology/repology#752

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment